Can't get photon connected to wifi

My photon flashes green forever and when I put it into listening mode (flash blue fast) and connect to wifi, it never works.
I usually am able to figure these things out but this one is strange.

Things I tried:
Using iPhone app to connect to WiFi
Using CLI to connect to Wifi
Using usb serial to connect to wifi
DFU flash from CLI
Tinker flash from CLI
Get out an old access point, connect it to the internet, and test it with that

It always either flashes green or flashes blue after I put it into listening mode. It never breathes blue.

Also when I do try to connect it to the wifi using the first 3 ways I listed, it tells me that is is done changing the wifi but it doesn’t connect. Flashes green and then flashes blue after this.


SSID: DCN-Resident
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3
Security Cipher 1=AES, 2=TKIP, 3=AES+TKIP: 2
Password: AC86fm!6
Thanks! Wait while I save those credentials...

Awesome. Now we'll connect!

If you see a pulsing cyan light, your device
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit to debug.

Particle <3 you!


wsip-174-77-39-20:~ nina$ npm update particle-cli
wsip-174-77-39-20:~ nina$ particle update

> Your device is ready for a system update.
> This process should take about 30 seconds. Here it goes!

! System firmware update successfully completed!

> Your device should now restart automatically.

wsip-174-77-39-20:~ nina$ particle flash --usb tinker
Found DFU device 2b04:d006
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download	[=========================] 100%         3952 bytes
Download done.
File downloaded successfully

Flash success!
wsip-174-77-39-20:~ nina$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: DCN-Resi
? Should I try to auto-detect the wireless security type? Yes
> Detected WPA2(PSK/AES/AES) security
Attempting to configure Wi-Fi on /dev/cu.usbmodem14611
? Wi-Fi Password AC86fm!6
Done! Your device should now restart.

Give > particle doctor < a try.

1 Like

Ok I tried doctor and it went to breathing cyan for a couple seconds but then back to the old problem. Although now it actually shows the photon is online with tinker on the ide, It does the same thing. The green will again flash for a bit and then it will change to blue flashing. Since it lets me use tinker now, I tried it and it didn’t actually work either, device error.

Is that blue flashing, or cyan flashing? If the latter, are there any other colors in between, like orange/red?

It’s not cyan like it is when it breathes. It’s dark blue.

I tried doctor again a few times and it does seem to usually get it connected properly and goes to cyan breathing but then either by itself or after restart for some reason it wants to mess up again and not work :confused:

Doctor seems to temporarily fix it.

Blinking blue would indicate Listening Mode.

Is your code clearing WiFi credentials or entering Listening Mode?
Could it be that the SETUP button (or the respective solder pad underneath the device) is “shorted” to GND?
Is your Photon connected to a PC which might try to set the baudrate to 28800 on the USB port?

These are possible causes for a Photon to enter Listening Mode.

1 Like

I forgot to respond but I tried your ideas and tried to doctor again and it just fixed. Don’t know exactly why but it works now. Maybe it was the baud thing because I also used a new pc?