Photon not showing its WiFi [SOLVED]

I have tried two methods:

  1. the mobile app method, but it is not discoverable through WiFi.
  2. using particle setup on my mac. It notices a photon connected through USB, but can’t connect it to WiFi either…

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

No nearby Photons detected. Try the particle help command for more information.
? Would you like to wait and monitor for Photons entering setup mode? (Y/n)

Any ideas? Thanks in advance!

With the device in listening mode, try Particle serial wifi from the CLI, and follow the steps. You might have to claim it afterwards if that wasn’t done before.

Can you please confirm the Photon is in listening mode? https://docs.particle.io/guide/getting-started/modes/photon/#listening-mode

It’s definitely in listening mode (blinking blue light)

I tried Particle serial wifi and it seemed to get further along in the process (actually asked me to enter in WiFi credentials), but then it showed me this error “! Something went wrong: Serial timed out”. Once this happens, the light stays a constant blue on my Photon and never goes into a proper connected state.

I have two other Photons + a couple Cores that I’ve used in the past, but this one is acting strange…

Thanks for sticking with us!
Let’s try something else then. Could you make sure the CLI is updated to the latest version through npm. Then, with he photon in DFU mode, try particle update. Follow that up by DFU mode and particle flash --usb tinker. Once that’s done, try erasing the credentials by holding setup for ten seconds, after which you could try the serial wifi again.

Let us know if that works?

1 Like

This is good advice, and one that I’ve seen written up several times. It’s sometimes needed for photons still running the original manufacturing firmware. Seems like a good candidate for writing up and being placed in a getting connected FAQ?

3 Likes

This worked! Thanks!
DFU Mode - particle update
DFU Mode - particle flash --usb tinker
ERASE WiFi credentials Mode
Listening Mode - particle serial wifi

Glad you’re up and running again. Do let us know if you run into other/further issues!