Photon Can't Connect to WIFI

This is my first particle device so I’m a bit of a NOOB. I have a Photon and can’t get it to connect to WIFI. The photon boots to “listening” mode (blinking dark blue). I’m trying to connect to it via a Mac.

Here’s what I’ve tried:

The standard laptop setup

  • The photon never shows up on wifi

The phone app setup

  • Same problem

Connecting via CLI

  • I’ve successfully (I think) updated the firmware via DFU
  • I’ve tried the PARTICLE SERIAL WIFI process and it hangs when trying to communicate with the modem
  • I can successfully get it to PARTICLE SERIAL LIST, but it times out when I try to IDENTIFY or get the MAC
  • I’ve also tried to flash it back to tinker with the same result

Any ideas?

1 Like

With particle serial wifi try to avoid any autoscan/autoselect options and enter your data manually

Thanks for your reply. I tried that and it still has when communicating with the Photon.

Can you post the full CLI output?

You could also try http://setup.particle.io

I tried the setup with no luck. Here’s the CLI output showing my timeout issues with identify and mac:

lat-bcummings1:~ bcummings$ particle --version
1.22.0
lat-bcummings1:~ bcummings$ particle serial list
Found 1 device connected via serial:
/dev/cu.usbmodem1411 - Photon
lat-bcummings1:~ bcummings$ particle serial mac
! serial: Serial timed out
lat-bcummings1:~ bcummings$ particle serial identify
! serial: Serial timed out

Here’s the CLI output of the serial wifi setup (manual only as you suggested). You’ll notice that it stops on “Attempting to configure” it just hangs:

lat-bcummings1:~ bcummings$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? No
Attempting to configure Wi-Fi on /dev/cu.usbmodem1411

Ah… Weird.

Can you disconnect and connect the Photon then place in Listening mode again before trying?

Otherwise, place it in DFU mode, run particle update before configuring wifi.

I unplugged it several times and ran the update twice. Same result.

Hmm… Can you place the device in Listening mode and try using particle setup?

Particle setup is what I first tried before particle serial wifi. Same result.

Sorry for the long journey to get it connected. What happens when you use particle setup? Does the photon blink cyan?

@kennethlimcp, it might be time to simply connect to the Photon (while in Listening Mode) with a terminal program and go that route. It may also be worth changing the USB cable just in case.

1 Like

@bcummings you can also try to use a serial terminal software like Putty or Coolterm to connect and send w to the Photon in listening mode.

1 Like

Thanks. I tried that using Mac terminal and screen /dev/devicename but was unable to get past a blank screen. Do you know of an app for the Mac that works or should I just dig up a PC and use PuTTY?

You can download Coolterm.

using screen /dev/tty.usbmodemXXX 9600, typing w should work. A GUI is more friendly though :slight_smile:

I tried connecting via screen and using Coolterm. I never got past a blank screen. I also temporarily set my wifi network to open and ran the setup utility again. Same result. Below is the output:

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

No nearby Photons detected. Try the particle help command for more information.
? Would you like to wait and monitor for Photons entering setup mode? No

Ok, bye! Don’t forget particle help if you’re stuck! <3

I’m starting to wonder if I have a defective unit?

@bcummings when you use coolterm, did you hit w in Listening mode?

Has this device ever been used before?
If so, there might be some “sticky” settings that might get in your way (e.g. WiFi.useStaticIP() or WiFi.selectAntenna(ANT_EXTERNAL)) which may need resetting in code first.

And to repeat Kenneth’s hint, when you are “stuck” on a blank screen in CoolTerm the device is actually waiting for you to send a command (e.g. w to set up your WiFi).

The device hasn’t been used before, although I haven’t been able to connect to it to see for sure. And yes, by stuck, I mean doesn’t respond to keystrokes. I tried W and I with no response.

Update: I ended up getting a new Photon from support. I had it working in minutes. Thanks all for your help.

2 Likes