Can't setup Photon

I know this topic have been cover several times, but it seems that none of the solution works for me:
On the day I got the Photon, after numerous attempts, I finally managed to get the softAP from the photon and set it up. Few weeks later, I kind of messed it up and try to reset it, and I have no luck connecting it back to the internet. I have tried:

  1. Go to listen mode and try with phone app again
  2. Re-flash firmware 0.5.2 (once with terminal, and today with the new firmware manager tool)
  3. particle setup, which doesn’t work since it can’t detect the wifi
  4. particle serial wifi, which I was able to enter the said and password, but then the photon got stuck in looking for internet mode

I also ran particle serial inspect, and everything passed. Please help!

What’s that? Can you describe the color pattern?

Yes, what ScruffR said about the colors.

What colors are displayed after you enter the Wi-Fi credentials? It will start out blinking green, but what happens after that? Is there blinking cyan (light blue)? Fast blinking cyan? Is there any orange or red? Does it go back to blinking green again, or back to blinking blue?

1 Like
  1. Fast green blink for about 40 seconds
  2. Slower blue blink for as long as I can see


Try ‘particle update’ and ‘particle flash --usb tinker’, both in DFU mode. Then give ‘particle serial wifi’ another shot in listening mode.

Is this actually blue or rather cyan?

I tried but it is not working. particle update saids ! System firmware update successfully completed!, while particle flash --usb tinker gives off a dfu-util: Invalid DFU suffix signature, but soon followed with dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!, … , Download done and ‘Flash success!’. I hold the setup button to go back to listening mode, use particle serial wifi, and the blue light stop flashing while I was entering, and jump back to flashing green (restart I guess), and back to slower blue blink. I try particle list and confirm I don’t have the photon register.

I am pretty sure it is blue, plus it is blinking way too slow for “CONNECTING TO THE CLOUD” and way too fast for “CONNECTED”.

Can you post a video of that blue flashing?

The missing DFU suffix warning is normal and ignorable.

If you can’t get a cloud connection (breathing cyan or breathing magenta in Safe Mode) you won’t be able to claim the device.
But once you get there (e.g. via a different WiFi network like your mobile hotspot), you can use

particle device add <yourDeviceID>

BTW, what encryption are you using (open, WEP, WPA, WPA2)?
Can you post the full output CLI gives you with particle serial wifi?
Don’t let CLI scan for your network, enter the data manually!

  1. Video: YouTube. Might still be processing. I just cut about 12 seconds of the who thing because my internet is not fast

  2. Manually enter network config (same network) : I check the router config & phone wifi config, and I can’t tell if it is using wpa or wpa2, so i tried both. with wpa2 it goes from green to blue, but with wpa it just got stuck in rapid green blink, until i give up 5 minutes later and try the next one

  3. Manually enter network config (open mobile hotspot) : same. I put my phone right next to the photon, cli the config, it goes from rapid green to slower blue for another 5 minutes now.

I have also try particle keys server just in case. no help


Did you by any chance have a static IP set or selected the external antenna previously which might hinder your connection now?

I don’t think so, but I am also not entirely sure. I have tried some examples from the Particle Build IDE before I reset it, and I can’t recall which one I have tried. Also wouldn’t re-flash the firmware reset back to default config?

Nope. These settings are sticky and have to be actively reverted, since they’d need to be set for Safe Mode too, which doesn’t run any of your code

1 Like