Particle photon blinking green

photon
Tags: #<Tag:0x00007f0392fb3460>

#1

Hi, I have a particle photon that I am trying to claim. It just sits there and blinks green. I can get into DFU mode (which is way trickier than implied). I can get into listen mode. Have followed multiple posts on what to do in this situation, flashing tinker, device doctor, etc. The farthest I can get to is verifying device ownership using the app, where it says “Setup Failed at claiming your particle device, if your particle device LED Is blinking in blue or green this means that you provided wrong Wi-Fi credentials, please try setup process again”. I know that I am typing in the correct wifi credentials as I have a second photon that is working perfectly fine.

Please advise me on any changes that can be made.

thanks.


#2

@paravorheim, (rapid) flashing green means it is not connecting to WiFi. Did you make sure to enter the correct WiFi passphrase. Does your router SSID have odd characters or spaces in its name? What about the passphrase?

Also, some routers offer 2.4GHz and 5GHz WiFi bands with the same name. This can be problematic for the Photon. The solution is to change the SSID of one of those bands.


#3

SSID is only letters, no spaces. passphrase has one special character *. Router is only offering 2.4GHz band, no 5GHz.


#4

@paravorheim, have you looked at the troubleshooting guide:

https://docs.particle.io/tutorials/device-os/led/photon/#wi-fi-module-not-connected

Is the “blinking” green a “breathing” green or a rapid-flashing green. Take a look at the guide and let me know. I suggest you reset the WiFi credentials of your photon (hold the SETUP button down, flick RESET and keep holding SETUP for 10 ses until you get a blinking blue LED). Then you could use the mobile app or, if you have Particle CLI installed, used it to configure your device via a USB connection.

You can also try Step 2a here:
https://docs.particle.io/quickstart/photon/#connect-your-photon


#5

It is blinking green per troubleshooting guide. I have tried resetting wifi credentials and did not have luck with connecting the device using mobile pap, CLI, or USB connection. All three did not work.


#6

@paravorheim, are you running on Windows or Linux/Mac? Which version of CLI do you have?


#7

version 1.38.0


#8

Windows (7/8/10?) or Linux/Mac?


#9

mac


#10

I am not familiar with Macs. You may want to try using setup.particle.io to see if that will work for you.


#11

You mention you’re having difficulty with USB/CLI connection. Are you using the provided Particle cable? If you are using a third party cable ,can you ensure it has data connectivity, and not just power?


#12

I did not buy the kit, just the board. The cable I am using has data connectivity, I have confirmed. The connection is not the problem. Rather, it is the ability for me to get back to a regularly functioning Photon. I am able to flash just fine (at least, according to CLI). Getting the device to actually connect to wifi/cloud, however, is the main issue.


#13

@paravorheim, have you tried connecting your Photon via USB and doing a “particle update” via the CLI?


#14

Particle update was ‘successful’. However, after setup via setup.particle.io, it seems to not connect to wifi (even though it can find the SSID just fine) and continues to blink green.


#15

@paravorheim, was this Photon ever used with an external antenna? Did it have a static IP?


#16

No, it was not used with an external antenna. I do not think it had a static IP, and I reset the device with device doctor to use dynamic IP previously.


#17

@paravorheim, if possible, can you try with a mobile hotspot like your phone. BTW, I assume that the green flashing is rapid flashing. Is it?


#18

Well, that worked. Do you think it is just a range issue?


#19

@paravorheim, unless you are very far from your router, I would say your router may be doing MAC filtering or is not running DHCP. You may want to verify its configuration. It seems your routers is not handshaking with your Photon.


#20

I will get back to you when I mess around with the router. Rebooting the router did not fix the problem.