Connecting Photon to WIFI

I am relatively new to particle photon but I’ve so far managed to set it up and flash some code and get it to run some servos using the Blynk app. Today, I connected my photon via usb and encountered problems with connecting to the internet. So upon connecting it to my USB port, it would blink green (looking for internet I assume). I’m not sure why it isn’t connecting to my internet network, which is has done so in the past. Ive been fishing the forums and attempted using the particle CLI. Through the CLI I tried configuring the my SSID and password. The final message from the cli stated " Done! Your device should now restart." However, there was no change in activity of the RGB; still blinking green.

Any other colors than green visible?
WiFi coverage okay (try moving closer to the router)?
What exactly did you try in the CLI?


Holding down SETUP begins the dark blue blinking (so searching for network). On the CLI I’ve tried “particle setup” but I get the message that it hasn’t connected to the cloud. Here’s the message:

EDIT: I’ve also, I’ve tried entering SAFE MODE but no success. Safe Mode requires wifi connection so it isn’t able to enter safe mode. I also updated the firmware using dfu mode but the same green blinking persists once it restarts after updating.