Particle photon blinking green

photon
Tags: #<Tag:0x00007f0390cfbdc8>

#21

I went through router settings, and DHCP is on, no MAC filtering is happening. Any ideas? Short of setting my router to completely normal settings?


#22

@paravorheim are there free IP addresses for the DHCP to lease out? Is the LED flashing green RAPIDLY (very fast blink) or MODERATELY (about twice per second)? How far is the Photon from the router?


#23

Try disabling your firewall. my Xfinity router blocks port 5683 (outbound CoAP port) at all but its lowest firewall settings, and a Photon will never connect when that’s blocked.


#24

It is a very fast blink. @ParticleD, I disabled my firewall completely and still no connection. Unless my modem or ISP is blocking that port somehow, which doesn’t make sense to me.


#25

It’s difficult to pinpoint the exact cause without having access to everything that you’re working with, but the fact you were able to get it online with your hotspot and not the router seems to imply the router is still not allowing something through for whatever reason.

I would think it’s unreasonable to think your ISP is blocking the port or protocol, so I’d be inclined to think there’s something on the router that’s not playing nice. peekay123’s suggestions don’t seem unreasonable either in terms of potential causes.