Cannot setup a new Photon

I’m at a loss as to what to do next. A Photon continuously blinks blue and I cannot get past this stage. This is what I have done so far and I welcome any further suggestions (even if it is to throw it in the bin as I’ve wasted so much time already):

  1. Started by trying to setup wifi credentials using my android phone - phone could not disconnect from the photon once it had the wifi settings.

  2. Updated the firmware (it was very old) using dfu-util and tried again. Same result.

  3. Tried a different usb cable and computer and used particle cli to update firmware - update worked. Then tried particle setup and failed after receiving wifi settings (yes, the settings are correct). Still flashing blue.

At this stage I have exhausted all my knowledge. Just to double check I took a new photon out the packaging and it set up perfectly. I now have 11 working photons and 1 obstinate one. Any suggestions from the gurus before I bin it?

Since you’ve got the CLI, could you place it in DFU mode and issue particle update, as well as particle flash --usb tinker, and then use particle serial wifi in listening mode? If you could post a screenshot of the output of those, that’d be great.

1 Like

Thanks for the reply @Moors7

Particle update finishes with no problems - after the update the photon goes into blue flashing mode:

C:\Users\Peter>particle update
> Your device is ready for a system update.
> This process should take about 30 seconds. Here goes!
! System firmware update successfully completed!
> Your device should now restart automatically.

After particle flash --usb tinker: again no problem. Completes and then flashes blue.

C:\Users\Peter>particle flash --usb tinker
Found DFU device 2b04:d006
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D C:\Users\Peter\AppData\Roaming\npm\node_modules\particle-cli\binaries\photon_tinker.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device…
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash "
Downloading to address = 0x080a0000, size = 3952
Download [=========================] 100% 3952 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!

Flash success!

Finally ran particle serial wifi and entered my wifi credentials - particle accepted them and is now flashing cyan for a few seconds and then ends with a solid red colour for a brief moment. Then back to flashes cyan and then solid red again.

Thanks for the help so far. Any further suggestions - seems we are getting somewhere.

Finally solved the problem. Ran particle identify in listening mode to get the ID of the device and then ran particle keys doctor on the device ID - all is well and connected back to the cloud breathing cyan - now to claim it. :slight_smile:

2 Likes