My new Photon does not connect to my Wifi


I received my new Internet Button by the end of august. I was trying to set it up this week end, but nothing seems to work.

  • First I used the Android App. When connected to the photon, it was not able to locate any wifi. If I entered it manually the App crashed -I think the reason is that the wifi has no security-.

  • When configuring it using particle CLI the device was not able again of finding any wifi network, and it did not connect when setting the credentials manually

  • After serveral hours of tests, I updated the firmware to version 0.4.4. Now the device finds the wifi network, but it is not able to connect to it. The additional problem is that I am not able any more to reset it to the no-wifi-configured setting. After reset it goes flashing green and when pressing SETUP it transitions either to solid gren or led off, no flashing blue any more.

Any hint about what to do next? I have tried several networks and the Photon does not connect to any of them.


1 Like

To add more information: when the Photon is connected to the PC by USB, it ends up flashing cyan, I do not know exactly how. Now I have been able to configure another wifi, and it does not connect, but remains solid green -not flashing. And in its current state and connected via USB I can go back to the flashing blue configuration the normal way.

I have just tried again whith CLI and two different networks, one WEP and other WPA2 and the photon connected to the PC via USB. The result is the same, flashing green now and no connection. It is worth to say that the photon does not transition to flashing green by itself, it remains flasing cyan during all the process. It goes green once I reset the device. Flashes green now, previously it remained solid green.


1 Like

I’ve responded to your Zendesk Ticket!
Talk to you soon.

I am still waiting for any technical answer or advise. My paid-on-due-time photon is totally useless.