Photon Won't Connect To New Wifi Network

Hello, I recently purchased a photon, and during first-time setup, it worked perfectly, and continued to work fine for 2 weeks. I have since switched wifi networks, and the old network is no longer visible, which I have read may cause problems. My photon just flashes green, and when holding setup, the light turns off instead of turning blue. I cannot reset it at all using the setup and reset buttons. I have tried plugging it into my computer and using ‘particle serial wifi’ to connect it to my new network, but my new network is not displayed in the list, and the command prompt freezes if I try to enter the information manually. I even tried making a hotspot on my phone to connect the particle to via the command prompt, but that wifi network wasn’t detected either. I can see my neighbor’s wifi when it scans for networks, so I know it’s not that. Thanks in advance for the help.

Try holding SETUP while blinking green for 10+ sec till rapid blue flashing appears.
Don’t try to auto-scan for networks but enter the credentials manually.
Make sure your WiFi is 2.4GHz and not 5GHz.

Thanks for the quick response!

Unfortunately, holding setup does nothing, the lights just turn off, even holding it for 10 seconds, and when I let go it flashes white for a second then starts flashing green. I tried to enter credentials manually, but if I select no when it asks if I want to search for nearby networks, nothing happens. My network is dual-band.

Could you try doing particle update followed by particle flash --usb tinker, both while in DFU mode?
Then, give erasing the credentials another try?

1 Like

Can you put your device into DFU Mode?
If CLI gets stuck, you can use any other serial terminal programm like PuTTY and enter w.

Or you could flash a sketch that clears the old creds and direcly sets the new ones via WiFi.setCredentials().

I can’t switch device modes at all using the buttons on the photon, including switching to DFU mode. Is there another way I could switch to DFU mode?

What OS are you on?
In Windows you could go to cmd and run

mode COMx 14400

where COMx would be the COM port your device is registered under in DevMgr

If the RESET button doesn’t work, you can pull the RST pin to GND and in order to switch modes, you could hold SETUP while plugging in USB power.

Could you also provide a video of when you try to enter DFU and/or Listening Mode?
Also let the device run (blinking green) for a minute or so, before you try entering Listening Mode.
Another option might be to set the creds of your mobile hitspot so that the match the creds if your previous network.

I was able to host a hotspot on my phone with credentials matching the previous network, then use another phone with the particle app to connect the particle to my current wifi network. Thanks for the help!


Hi, I’ve managed to setup my photon to my WiFi network at home and that works fine. However when I try connecting to a new network at my school, I keep getting the message ‘can’t verify product ownership’. I deleted the device from my account, tried resetting, holding the setup butt until it starts blinking fast but still no luck. How can I solve this issue?

When your device is already claimed to your account you can just skip the ownership part.
Also are you sure your school network does allow to connect?
Are the required ports open on the school firewall?
Does your network use a captive portal? These are not supported by Photon.

If you can use CLI or a serial terminal program to communicate with the Photon, using that to set WiFi credentials may be easier than the mobile app.

BTW, unclaiming a device just to reclaim it again never solves such problems.

The network should be okay, I set up a new router…

This is what I get when I try to connect, but the WiFi network is working just fine. Does anyone know what to do

What is the device currently doing, and have you tried the CLI already?

blinking cyan with a burst of orange every now and then. My computer didn’t allow CLI to be installed but I think I’m going to try another computer. What is it exactely that I have to do on CLI then?

If you search for “orange LED”, you’ll find quite a few topics discussing this already.
You’re going to want to try “particle doctor” in the CLI and follow the steps. There’s most likely something wrong with the keys on your device.