Unable to claim device

A while ago my photon dropped off the network for some unknown reason and I didn’t have time to look at the problem then. Now I am trying to get it back online, and I can’t get it online.

It goes through all the steps, and then fails when it is verifying product ownership.

When it changes to this screen, the photon is blinking white, not breathing.

Any ideas to what to do?

Hi,

I’ve had mixed results with the app over time.

Are you set up to use the Particle-CLI, the Command line interface?

If not try looking through:-

https://docs.particle.io/guide/getting-started/connect/photon/

Are you using the same wifi location that you set the photon up on originaly? Has there been any wifi changes if it is? Are you using mac/Apple or PC/Android ?

Also if you log in to the console, is the photon listed on your account?

It is the same wifi location, same wifi access point, only difference is that my internet bandwidth got doubled, I even still got the same IP.

I tried to get it back on my network with my Android based phone, and now I tried with the Particle-CLI, here is what I got from that.

! OOPS: I was unable to scan for nearby Wi-Fi networks (-___-)

? We can still proceed in 'manual' mode. Would you like to continue? Yes

! PROTIP: Manual mode will prompt you to manage the Wi-Fi connection of your computer when it's necessary.
! PROTIP: To proceed, you will need to be able to manually change the Wi-Fi connectivity of your computer.
! PROTIP: Your Photon will appear in your computer's list of Wi-Fi networks with a name like, Photon-XXXX
! PROTIP: Where XXXX is a string of random letters and/or numbers unique to that specific Photon.

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

> Obtained magical secure claim code.

! PROTIP: There was a network error while connecting to the cloud...
! PROTIP: We need an active internet connection to successfully complete setup.
! PROTIP: Are you currently connected to the internet? Please double-check and try again.

I am 100% sure I got a working internet connection. I even tried to do it with an active SSH connection open, just sending constant garbage through that to detect any outtages. Only Particle-CLI can’t get connection.

In the concole I only got my old Core online and running, the Photon isn’t there.

Make sure the CLI is up to date, and then give particle serial wifi a shot while in listening mode. Enter everything manually if possible. Don’t know why, but it’s shown to be more reliable than the ‘auto setup’.

How do I do that? I installed it quite a while ago, do I need to remove it and install again, or is there a command to just update it?

Found it!

I tried the serial wifi command, and it ended with

Done! Your device should now restart.

It restarted, and then went back to flashing like this

Still not showing up in console either.

This is known as red burst issue indicating an error with the keys.
To cure it, put your device into DFU Mode and execute

particle keys server
particle keys doctor <yourDeviceID>

That fixed it, but what a mess getting the dfu-utils and openssl path fixed so it could find them.

Now I wonder why it went into that problem at all. Are there any known thing that will bring it into that?

@Mikey, this would have been a question to answer, in order to possibly spare you this

If you said you were on Windows we might have guided you to the Windows installer that does all that for you :wink:

One possible reason for this may be a prolonged absence of the cloud. Keys get changed from time to time and if your device misses to many updates your device won’t be trusted anymore.

I actually found that on my own, it installed it all, but the PATH was still missing.