Photon not connecting to wifi

I just received my new Photon in the mail a few days ago and I’m having a heck of time getting it to connect to my home wifi network.

My home network is fairly simple. I have a non-wireless router connected to the WAN, and a Ubiquiti wireless access point (UAP-PRO, which is dual band with the same SSID).

I plugged in the Photon to my desktop via USB and attempted to connect the Photon to the cloud using the Particle app on my Nexus 9 tablet. When scanning for a wifi network, the correct SSID was shown, but attempting to connect to it would result in an error on the final step.

I then put the Photon back in setup mode and tried to configure it via serial using particle-cli. Manually entering the wifi SSID and parameters (“particle serial wifi”) would give me a “Done! Your device should now restart.” message and the Photon would blink green. If I go the “particle setup” route, then after entering the wifi information, the message “Obtaining device information” just repeats over and over.

After no success connecting to my normal wireless access point, I grabbed an older Netgear router from storage and fired that up. Still no go. In fact, the Photon would never detect that SSID when scanning, even though I can connect my phone and tablet to it.

I then put the Photon into DFU mode, flashed the 4.7 firmware and tried everything again. Still no go.

I connected to the Photon using Putty via the COM port and configured wifi from there. Still no go. Same result: the Photon just blinks green.

The Photon will never detect my Netgear access point. Manually entering the SSID and wifi parameters does not connect either.

Oddly enough, I setup my Android phone as a hotspot and then using the Particle app on my tablet, I was able to connect the Photon to the hotspot and finally got the breathing cyan light!

The hotspot has the exactly same security configuration (WPA2 AES) and password as my Ubiquiti AP. I’ve tried a range of different security modes on the Netgear: different SSIDs, WPA TPIK, WPA2 AES, WPA/WPA2 mixed, etc. The Photon refuses to see or connect to any of the access points.

What am I missing here?

I’m sorry to hear of you having a hard time.

Since the Photon only supports 2.4GHz WiFi, could you try to deactivate the 5GHz or use two seperate SSIDs for the two bands and only provide the 2.4GHz credentials to the Photon?
Could it be that your router firewall blocks the CoAP port (5683)?

@binaryryan I have a couple of thoughts on this,

the Ubiquiti is an enterprise product (that i know of) while it is only an access point, do you have any of the enterprise level tools / hardware / features running on it? What about your WAN, are you using any enterprise level hardware with that (i.e. enterprise level Cisco Gear?) Who makes the non wireless router? do you have any weird firewall settings preventing this from working? If you put your AP on a DMZ does it still not work?

What was the actual error you are getting?

as @ScruffR said check to see if that port is blocked.

Hi ScruffR. Thanks for the quick reply.

My Ubiquiti AP serves both 2.4Ghz and 5Ghz under the same SSID. To rule that out as an issue, when I configured the Netgear router I setup the 2.4Ghz band only to have a unique SSID. The Photon still would not see that SSID when scanning, and would not connect if I configured the Photon to connect to the SSID manually via Putty or particle-cli.

Just to be clear, you’re saying that the Photon needs to connect to port 5638 on an external server, right? My firewall is not configured to block outbound access to any ports.

Thanks for the reply @MobileRez.

My non-wireless router is a Ubiquiti Edgerouter Lite. The configuration is standard, pretty much as it came out of the box. There are no firewall rules configured that would block any outbound ports.

The UAP PRO is in standard configuration too. Nothing unique or special is configured. It’s simply configured with a static IP on my network and is bridging wireless traffic to the wired network. Putting the UAP in the DMZ shouldn’t make a difference since its in bridge mode (the Photon would have a different IP and therefore not in the DMZ). I’ll give it a shot though.

Unfortunately I am unable to reproduce the error message I was getting on the tablet from the Particle app. I do remember that the error would appear at the “Verifying product ownership” step.

When I attempt the setup process in the app now, it completes (checks off all the steps, even verifying product ownership) and then gives me the “setup done” message. Meanwhile the Photon is still sitting there blinking green.

Is there difference between slower blinking green and faster blinking green? When I setup the Photon on my phone’s hotspot, it starts by blinking slow green for a second or two, then blinks faster green for a second or two, then fast cyan (which I assume is connecting to the cloud) and finally breathing cyan (connected).

When trying to connect to my AP or test wireless router, it never gets past the slower green blink. Does that means it’s trying to connect to wifi? And faster blinking green means it connected to Wifi but is completing whatever handshaking, DHCP, etc is necessary?

Yes, it would blink slower while looking for a network for which it has credentials, and fast green would be while receiving the IP via DHCP.
Fast cyan is initial cloud handshake.

Maybe just erase all the WiFi credentials from the Photon (hold SETUP for 10+ sec till it fast flashes blue) and add only the credentials for your Netgear which should have its own SSID and only running on 2.4GHz.

Also check what channel your WiFi is using and try to stay below 12.


One maybe difficult suggestion: Could you just grab your Netgear router and get it hooked up to some other network, or bypass your Ubiquiti router?
Or you could even just try to activate DHCP on the Netgear and leave it unconnected, this way you should at least see the rapid green flashing when the IP gets handed out.

Definitely below 12 as I’m in the United States.

That’s a great suggestion. I’ll give that a shot too.

I configured the Netgear router for NAT instead of bridging, and enabled the DHCP server. Using particle-cli I connected the Photon to the Netgear’s SSID and was connected almost immediately. Breathing cyan.

1 Like

Actually, nevermind. I pulled the power and restarted the Photon and it sat there blinking green again. Now it’s not seeing the Netgear SSID, or any other SSIDs.

Hmm, have you ever flashed any other application FW than the factory Tinker?
Do you see the same behaviour in Safe Mode?

How do you know that the Photon is not seeing the SSIDs? Or do you just derive this from the not blinking green quickly?

I have not.

Not familiar with Safe Mode. I’ll look it up and report back.

I should have been clearer. When I say that Photon is “not seeing” the SSIDs, I’m referring to the step in the setup process using the Particle app where it scans for available wifi networks. I’ll frequently arrive at that step and no networks will be found, even though there are at least 3-4 SSIDs in range (2 are mine, the other neighbors’).

I put the Photon in safe mode but there was no difference in the outcome. Still just flashing green.

I also cleared the wifi credentials by holding the SETUP button until it flashed blue rapidly and reconfigured the wifi network using particle-cli. Still flashing green and will not connect to the wireless network.

Edit: I also cleared the credentials and configured the Photon using the Particle Android app. It completes and says the device is connected and setup, but the LED just flashes green still.

This is very, very odd.

Maybe you could open a support ticket or mail hello(at)particle.io with a reference to this thread. This way Particle could have a deeper look into your hardware.

Hi Binaryryan,

Just to level set here, are you running the particle-cli on a computer which has a wireless adapter in it? The particle-cli scan is only a check to find wireless networks from your computer’s perspective. The scan is not done from the Photon.
If you do not have a wireless card in your computer, then you just use manual mode and enter the known SSID manually with the choice of the proper encryption (WEP, WEP2, …) and enter the password. If the Photon responds that it set all the values correctly, and you entered the appropriate values, then it should work.
I normally monitor my units using the Particle Dashboard. There you can see if the unit is properly registered (on the Devices tab) and you can see the unit come online or not (on the Logs tab).

Yes, I’ve used particle-cli from a laptop with a wireless adapter.

Is the same true when scanning from the Particle Android app? Scanning for wifi from particle-cli always returns results, but scanning from the Particle app returns no results 98% of the time.

I’m quite disapointed. I have the same fault. Tomorrow I’ll try another router on another network.
I’ve tried various things and never got the past the green/blue blinking.

My router is a Netgear CG3700EMR. It does not contain a firewall. It’s not possible to turn off 5GHz but I renamed it very different to the 2.4GHz. I’ve tried with varous security settings. Lastly total open 2.4GHz down to 54mbit/s and channel 1, but no cyan light or other.

I followed the guide for ufu-util and flashed 0.4.9 release with good resault. But no change in connection. I’ve done the particle setup and particle serial wifi as iPhone setup a lot of times… no resault.

Ofc the Iphone installer goes all the way down to veryfie… but there it fails.

Could you try connecting it to a mobile hotspot, like that from you iPhone? You can set the credentials for that using the CLI with particle serial wifi. That should rule out issues with the device.
Any chance there’s a led pattern to be seen (quickly blinking orange for example)?

Great, that worked! But it does sadly not explain the fault I have had with my Router.

BR

At least we know the device is okay, and it’s an issue with your router, which helps.
What channel are you on (<11?). Using some fancy encryption? DHCP settings that might mess things up? MAC filtering?

Nope, as I said before. tried small capitals in SSID no encryption and channel 1 to 5 tested.

DHCP pool 192.168.0.10 to 99… so nothing there either. And no possibillity to change any firewall rules…

I did find a box stating: Disable IPv4 Firewall Protection
So I checked it. But no change in connection. Strange anyhow… because there is no settings regarding firewall in this device.