Photon will not connect to Wifi no matter what


This has been the most frustrating consumer electronics product I have ever worked with. I have two photon chips that I have been working with for almost a year now and I have yet to actually get them connected to the internet in my home. Here is a list of the things that I have tried:

-Using the Android interface. It sees the device but always encounters an error when trying to connect.
-Using the “particle setup” command in the command line. The photon is always unable to find local networks “Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…” I use the manual setup and get another infinitely repeating message when I enter my network information. “Obtaining device information…” I let this go on for about a half an hour and it doesn’t change. My network is 2.4 Ghz.
-Using the “particle setup wifi” has the exact same problems.
-I checked my router settings and I do not have any closed ports.

Is there anything I haven’t tried yet? I’ve been combing these forums and stackexchange for the past several months trying to figure this out.

Can you Tinkering D7 your Photons? Which RGB Color do you get?

Switch into DFU-Mode (connect Photon over USB to PC):
CLI: particle update and
CLI: particle flash --usb tinker

I guess you mean paritcle serial wifi, or not?
Have you tried not to let anything be done automatically, but entered everything manually?

Are you using WEP?
You say your network is 2.4GHz - does this mean it is 2.4GHz only or also?

What does the RGB LED do on your device?


My router broadcasts both 2.4 and 5GHz but they have different names. I am trying to connect it to the 2.4 one. The RGB is blinking blue, which the instructions say is listening mode. And yes, I did mean to type particle serial wifi. The security is WPA AES.

What is the exact error you get when using the Particle app on Android?

Just for safe measure I’d press and hold SETUP for 10+ sec to clear any previously stored credentials.
And then try again via particle serial wifi without any automatic network searching or security detection - enter it all manually.

Thanks for the response. What happens when I do this and deny the automatic scan is I get a message “Attempting to configure Wi-Fi on COM4” that lasts for several hours.

Please try running setup again after resetting your Photon and putting it back in blinking blue listen mode if needed.

This has happened after several times I ran setup again.

What OS are you on?
If Windows, do you see the device in DevMgr?
Have you got the drivers installed correctly?
Have you got a serial terminal program like PuTTY or CoolTerm? You could use these with the command “w” to provide WiFi credentials too.
Have you got the latest CLI installed (currently 1.21.0)?

I am using particle photon with pulse sensor and LCD ,
Now particle isn’t blinking at all and cant connect to WiFi ,when i plug USB the LCD and Pulse sensor both lights but can’t connect the particle to the Internet ?
Why ?

Maybe you want to remove all external circuitry and revert the firmware to the factory defaults.
In DFU Mode

particle update
particle flash --usb tinker

and then try to setup the WiFi again.

Could you post a video of that?

The update worked.
When I typed the second command it says “Error writing firmware…No DFU device found”

I’m running Windows 10, I installed the drivers as instructed and when I run commands it detects the photon over usb. I have been using cmd but I also have Windows Bash. In my device manager the photon is on COM4, there is a warning over it that looks like the triangle traffic sign. Windows insists that the drivers are up to date. I installed the latest CLI.

The device can appear as (at least) two different types of devices in DevMgr (Serial COM or DFU device).
If it appears as COM4 you haven’t put the device into DFU Mode (blinking yellow).
Or - less likely - you have installed the serial drivers while the device was in DFU Mode and now Windows uses incompatible drivers for that mode.