Multiple Issues Trying to get First Photon Connected

Ok, where to start.
Got past Vista USB driver install.
Android set up fail (tried MANY times)
Used particle CLI to setup - hangs trying to connect to cloud (tried MANY times)
Can’t device add!
Is there a reason this thing costs as much as $19 when it doesn’t even work?

Looks like you successfully are seeing the device on USB. That is good.
You have found the device ID, That is good.

Is your Wi-Fi network 2.4Ghz? The Photon will not work on a 5Ghz network.

What color is the RGB LED, and what pattern?


When I do the particle setup and it fails repeatedly with “It doesn’t look like your Photon has made it to the cloud yet.” it stays flashing blue.

If I then run particle serial wifi after I’ve entered my wifi credentials and the message “Done! Your device should now restart” it turns to flashing green, and that’s it.

It sounds like your Photon is not liking your WEP password. Looking at your screenshot it doesn't appear to be a full WEP key, but maybe your passphrase which is used to generate the key. WEP keys are also a bit different than WPA/WPA2 passwords on the Photon in how you enter them. If there's any chance you'd be willing to switch to WPA or WPA2 encryption you will have an easier time, this is also better for your network security as well.

If you'd like to stick with WEP though, it should work... please follow these steps:

Here's an example of where to look in your router for your WEP key:

You probably need the first 10 byte key from your router, then enter 0005 before it as your WEP password during setup.

1 Like

I switched to WPA2. Still all the same issues. Fails to configure over the phone. Same results with particle.

Honestly it’s never this difficult… sorry @allegrojm!

Can you try the Particle CLI? Enter Listening Mode and run:

particle serial wifi

Follow the prompts, if you get it breathing cyan you can manually claim and rename.

Sorry BDdub but I’m proof positive it is this difficult. I believe I’ve tried particle serial wifi many times again already but did again for you. Same result, flashing blue, and after I enter my wifi credentials (WPA2), flashing green for several seconds then back to flashing blue, that’s it.

Hmm, thanks for trying that again. What channel (hopefully 1-13) and frequency (hopefully 2.4Ghz) is your router? Do you believe to have a good signal? Any firewalls? If you have an external antenna you can give that a try (maybe something is wrong with your RF switch/Antenna as defaulted to the Chip Antenna)?

Channel is six. Fequency is 2.4ghz. Signal is excellent. Router is brand new Asus RTAC1200 just out the box today. Had exactly the same results with my older DLINK router which has been working great for 8 years. Sooo, go figure, 2 very good routers with great reception for ALL my devices except this lemon.

I think we’ve tried just about everything I can think of @allegrojm, unless you have an external antenna to try. So please write into support and let them know we think there may be some issue with your Photon’s Hardware.

I have certainly done

expressed my concerns to your support

I have an external antenna. But if the chip defaults to it’s internal antenna, what good is the external one to get the device setup in the first place. I did try it but no go.

Could you try setting up a hotspot with your phone and connecting to that (using the CLI)? Just a random stab to see it that might work, no guarantees.

I don’t have that option on my phone.

While you are waiting for Particle support to help out, I will also mention that some folks have had trouble getting set up when there are many, many WiFi signals present for unknown reasons. If there is a way you can do the setup away from other WiFi signals or put the Photon as physically close to the router you are using and move other routers away, that might help.

I put the device right next to the router, with exactly the same results.

By some miracle after nearly 5 days of messing with this I suddenly got breathing cyan and was able to claim the device.

Unfortunately I can’t recall the sequence of hammer blows that got me to this point.

1 Like

You need to be on a machine that has WIFI itself!
If you are trying to initialize with a desktop PC and your wireless modem it will not work. It might work if you have WIFI in your Desktop.
The easiest way is with a True Android device, second choice would be a laptop with WIFI and all the windows drivers installed.
I finally gave up and bought an Android tablet.

Good Luck,