Trouble setting up photon

Trying to set this puppy up has been an exercise in frustration…

Router make and model
Linksys WAP54G
Network security (unsecured, WEP, WPA2, etc.)
WPA2-Personal
Environment (home, small office, enterprise, public network, etc.)
Home
Network topology (number of routers and/or range extenders, estimated number of devices connected to network)
Wireless hub attached to router
Internet Service Provider
ComFrickingCast
Any network settings that might diverge from the norm
None

Tried to access via smartphone, iOS(4S) and Android(MotoG)
Neither could connect.
Move to USB
particle.io is installed
when I run particle setup
I see

C:\Users\Dev>particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/
|_|                     https://particle.io/

> Setup is easy! Let's get started...
> It appears as though you are already logged in as robertflesch@gmail.com
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

> No nearby Photons detected. Try the `particle.js help` command for more information.
? Would you like to wait and monitor for Photons entering setup mode? (Y/n)

never finds it.
I am an electrical engineer and software dev, so I do know my way around such things.
Any suggestions before I sent this back? I assume I just got a bad one.

bob

I’d just skip all the magic WiFi and Photon searching.

It’s nice when it works on first try, but I don’t find it worth the hassle to get it to work if it doesn’t immediately.

I’d do

particle serial wifi
// don't auto scan, but enter info manually
// device should start breathing cyan
particle identify 
// note the device ID
particle device add <insertDeviceID>

particle serial wifi
worked like a charm

but particle identify returns
! serial: Serial timed out.

What gives? it works 10 seconds earlier…

You need to put the device into Listening Mode again by holding the SETUP button till it the RGB LED goes blue.
Before you enter the first set of WiFi credentials the device enters this mode by default.

2 Likes

ScruffR you da man!

I totally missed that I had to put it back in listening mode!

I just assumed it was listening when it was breathing…

2 Likes