Unable to setup Photon

So finally thought I would pull out the Photon and set it up…

Unfortunately when I follow the steps on an iOS device, I login to the Cloud, select add Photon, change to the Photon WiFi network and… nothing? nothing happens at this point and the app does not change

I have also tried from OSX with the local USB connection but get the following error

    Korolev:~ jamesas$ particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/
|_|                     https://particle.io/

> Setup is easy! Let's get started...
? Hello Stranger! This seems to be your first time here. What would you like to do? Loginarrow keys)
> Let's get you logged in!
? Please enter your email address: ***********
? Please enter your password: ***************
> Successfully completed login!

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

? Found "Photon-FMF9". Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

> Obtained magical secure claim code.

! PROTIP: There was a network error while connecting to the cloud...
! PROTIP: We need an active internet connection to successfully complete setup.
! PROTIP: Are you currently connected to the internet? Please double-check and try again.

Any ideas?

Andrew :smile:

1 Like

Try to only switch to the Photon network after you’ve been prompted to do so. In case of the CLI it seems that you didn’t have an internet connection when you were trying to connect. The same goes for the app. Only switch to the Photon when explicitely asked to do so. Alternatively, you could try particle setup wifi, and then don’t have it detect your security type automatically. That often works for me :smile:

1 Like

What has worked for me is to ensure that the 5Ghz network is a different name than the 2.4Ghz one. You can also switch the 2.4Ghz network to b/g only. This was the ticket for me. I have a linksys WRT1900AC router and I think this really confuses the not-so-capable wifi chips. I had this problem with my Sonos and HarmonyHub, too. Once I switched off or changed the name of the 5Ghz wifi network, everything started working. Hope this helps.