Unable to connect Photon to different network


I’m having a really hard time here.

I setup the Photon this morning on my iPhone hotspot, activated it, everything went ok, but now I’m trying to set it up on my home network, did everything they explained in the docs, but I can’t erase the wifi network on the Photon using this method https://docs.particle.io/guide/getting-started/modes/core/#wifi-network-reset

It keeps connecting to the iPhone no matter what, so I deleted the device from the dashboard, and now I can’t even program it because it’s not in the list, “particle serial wifi” command doesn’t work because my mac doesn’t see it on USB (! serial: No devices available via serial), “particle setup” command fails miserable at connecting the photon to the cloud.

! It doesn't look like your Photon has made it to the cloud yet.

? What would you like to do? (Use arrow keys)
❯ Reconfigure the Wi-Fi settings of the Photon 
  Check again to see if the Photon has connected 

And the led keeps flashing green

Tried to claim it vie the iOS app got this error after confirming the override:

Can you help me to connect my Photon to the cloud so I can finally start working on my project please. I tried everything, nothing works.

UPDATE: Ok so I managed to claim the photon back, still can’t to connect it via usb to update the firmware, same for dfu mode, my macbook doesn’t detect it even with dfu-util, and the led is breathing magenta, when i check the dashboard it’s says auto-update over and over again:


Hi @avatsaev,

Sorry about the slow reply! I’m glad you got your photon claimed again. If it’s back online, can you flash it from the web IDE, or send the updates using the over the air method?


Thank you Dave for your reply, I’m freaking out here (well freaking out is a bit exaggerated but still).

I tried to flash it from the web ide, nothing happens, the board remains in auto update mode for a few minutes and the restarts and does the same thing, like it’s stuck in some sort of loop.

Hi @avatsaev,

The photon now has a few modules (part1, part2, and your app is the third). Make sure you let it finish updating (blinking magenta), and don’t interrupt it. If you interrupt it you might need to start over. It’ll run through each of these updates when flashing from the IDE, and it might take a few minutes depending on your wifi connection / latency.

Don’t worry, it’ll finish updating if you let it :slight_smile:


Ok, so I tried to update OTA as you suggested and got this error, the board is still blinking magenta

Hi @avatsaev,

Ooh, I see what’s happening, sorry about that! You’re running a version of firmware that’s reporting a very old version. The cloud is trying to send you the update that gets sent the first time a device is unboxed.

I asked your device to stop doing that. The next time it resets, I think it should startup normally. Then you can flash it 046, and I’ll undo my override.


Oh, make sure you send part1 first, since the part2 upload won’t succeed until part1 is in place.


sent part one, trying to send part 2 now

Just as a followup, we talked offline for a bit. Switching USB cables let us upgrade over DFU mode, which fixed the issue.