Troubleshooting connecting to WIFI + DFU mode + USB firmware

I’ve been having repeated issues with multiple Photons, especially when trying to change the wifi network.

In this current iteration, I recently moved so I wanted to reset a Photon in a project, add the new wifi network, and then flash the current code.

This afternoon it was relatively straightforward to “reclaim” the device (as a side note, wouldn’t it be great if the iPhone app could accommodate changes in the wifi without going through the ownership process?), but when I turned it back on this evening, the device wouldn’t connect to the wifi. I was able to “reclaim” the device a number of times, but never did it reconnect to the Particle Cloud.

I have followed the entire thread here in addition to attempting to enter DFU mode and perform a factory reset, as suggested here.

At first, particle flash --factory tinker seemed to have worked, but the next suggested command (for the cc3000 chip) did not:

particle flash --usb cc3000
running dfu-util -l
Found DFU device 2b04:d006

Error writing firmware...file does not exist and no known app found.

At this point, the status light seems to always flash yellow. The device seems to be stuck in DFU mode, but it isn’t available through the terminal:

particle serial identify

! serial: No devices available via serial

Any suggestions? Thank you.

How are you changing the wifi network? Did you mean adding a Wifi credential to the Photon?

CC3000 is only for the Spark Core and not applicable to the Photon.

You can hold on to the SETUP button until it enters Listening mode, release and hold on to the SETUP button again until it blinks blue rapidly. This will clear all the wifi credentials.

Using the mobile app should now allow you to connect the Photon to the new wifi network :smiley:

How embarrassing that I was looking at the wrong documentation! Thank you very much kennethlimcp.

I tried the steps that you described, and it seems to have successfully taken me out of DFU mode and into setup mode – though there were issues with the last step of claiming ownership.

The iPhone app prompts me to override ownership (I was the previous owner but removed it from my account during the troubleshooting). If I select No, the setup completes successfully, but the device isn’t visible in my console. If I select Yes, all of the steps complete successfully with the exception of the final step (“verify device ownership”).

I then receive the message - “Setup failed at claiming your Particle device. If your particle is blinking blue or green this means that you provided wrong Wi-Fi credentials”. I’ve tried the setup process a number of times and I’m certain that the wifi password is correct. Are there any other configurations that lead to the same error?

Thanks for your help!

Is the device blinking blue or breathing cyan? You can try claiming it using:

Fascinating – I tried running particle setup through the cli, and it seems to have worked this time. Not sure why it worked there and not through the iPhone app.

There were a few error messages when scanning for wifi networks (“Your Photon encountered an error while trying to scan for nearby Wi-Fi networks. Retrying…”) but it ultimately returned the correct list. After this setup process, the photon successfully was configured and connected to the cloud.

Interesting – so the plot thickens: I just attempted to flashed the photon from Particle Build, and the request timed out the first few tries. After disconnecting, waiting a little bit, and then trying again, it seems to have flashed successfully and is now reconnected with the cloud. Great!

Thanks for your help @kennethlimcp! I’ll try to do the same with the other Photons tomorrow morning.

1 Like

Let us know if you still face issues. Always happy to help :smiley: