[SOLVED] Can't connect to Photon (Hotspot or Wifi)

I just got my Photon today and tried to set it up. Unfortunately, I’m on university wifi, which won’t work. So, I used my computer to share the wifi as WPA2 and attempted to setup the board with the iOS app, but it refused to connect to my computer’s shared wifi and the light on the board was flashing green fast. Then, I used my phone as a hotspot and attempted to setup the board using CLI, and it said it connected, but failed to show up on the cloud, and the light on the board was breathing white. I also tried the shared computer wifi using a secure VPN and it had the same problem as before. Is there anyway I can connect to the Photon on this university campus or am I going to have to wait till a break when I can take the board home?

Thanks a lot for your help.

If it’s a ‘fresh’ photon, updating its system firmware might help. You can do so using the CLI. First make sure you’ve got the latest version by using npm update -g particle-cli
And then, with your board in DFU mode, use 'particle update`.
See if that helps and let us know either way.

Thanks for your help Moors. After updating the firmware, I tried both the phone setup using computer shared wifi and the CLI setup on hotspot wifi again, and while no progress was made with the phone setup, the CLI setup causes the Photon to flash cyan with periodic flashes of yellow, which supposedly means it connected to the wifi but can’t reach the particle cloud, which the CLI confirms. What should I do next?


I fixed it! Because updating the firmware allowed it to connect to wifi but not the cloud, I reset the public key and doctored it and now it works great! Thanks for your help!

1 Like