My photon will not connect to wifi, please help

I just got my photon today, and was trying to set it up over the app. When i get to the part where i connect the photon to the wifi, The app tells me that Setup process couldn’t disconnect from the Particle device wifi network. There is an internal with the device. I tried resetting it, but i don’t know if I did it correctly. I also tried setting my photon up over usb, but during the final setup stage, the terminal just says that it is unable to connect the particle to the cloud.

Could you please provide more details about your system(s)?
Have you looked through the troubleshooting section in the docs?
What does your Photon signal (LED colors)?
What app are you using to talk to the Photon via USB?
Have you got particle cli?

I am using node.js and my terminal. The leds always stay blinking blue. What is particle cli?

I downloaded node.js and tried to connect to to the photon via terminal. When I am at the stage where I try and connect the particle to the cloud the leds stay blinking blue, but the particle never connects. What is particle.cli

Have a look: