Device Cloud Connection Fail

I am trying to connect my Photon to WiFi and it is all of a sudden failing, through both Android app and CLI, on the step where it connects to the “device cloud”.

It’s plugged into USB, and I’ve tried doing the factory reset multiple times, where it’s in blue blinking/listening mode as I’m going through the setup process.

I’ve also tried this, where it successfully updated the firmware:

sudo npm update -g particle-cli && particle update

And then went through the process again, but to no avail.

Any ideas on how to further troubleshoot this?

Have you been able to use the Photon successfully previously?

@kennethlimcp Yes. I’m not sure what I could’ve done to cause a device cloud connection error? Do I need to remove all the apps connected to my account? Something to do with device keys?

No you should not. Can you give me more details what were are doing and it entered that state?

  • hold the SETUP button until the RGB led turns off/blink blue
  • use particle serial wifi
  • send the credentials
  • let me know what happens :smile:


? Should I scan for nearby Wi-Fi networks? Yes
? Uh oh, no networks found. Try again? Yes

It can’t find any Wi-Fi networks. I then tried sending it manually through the CLI, but still doesn’t work.

When I try it through the Android app, the Photon does return a list of my WiFi networks. When sending credentials however, I still get the same error where it can’t connect to the device cloud.

Also, a particle list will return “No devices found.”

Were you using particle serial wifi

@kennethlimcp yes

Weird. I wonder if the CLI changed. Can you select No and continue from there to manually enter credentials

@kennethlimcp yep, I tried that too and it didn’t connect.

  • Is the photon blinking blue?
  • What is the output from the CLI?

Yes, it’s blinking blue. After entering manually, it said:

Thanks! Wait while I save those credentials...

Done! Your device should now restart.

still blinking blue, still plugged in to USB, and when I do:

njonas-macbookpro:~ njonas$ particle list
No devices found.

What I don’t understand is how this has worked before, and when I do a ‘factory reset’, I’m still having issues. Is there a way to perform a stronger reset?

particle list is for devices in your :cloud: account. It has nothing to do with USB connected devices but rather listing the devices online/offline.

Can you do a particle serial identify


njonas-macbookpro:~ njonas$ particle serial identify

Your device id is 1f0020000347343337373738

Tried particle serial wifi again, couldn’t find connection, typed it in manually, it restarted, and now it’s still blinking blue. Still stumped!

Weird…Can you use something like Coolterm and hit w

njonas-macbookpro:~ njonas$ w
 9:52  up 12 days, 10 mins, 2 users, load averages: 3.16 2.51 2.35
USER     TTY      FROM              LOGIN@  IDLE WHAT
njonas   console  -                20Aug15 12days -
njonas   s000     -                Thu20       - w

@njonas i meant this software -

@kennethlimcp Okay, I can better describe the error behavior now using CoolTerm.

Once I unplug and plug in the Photon, it breathes Cyan (I think it’s Cyan, it looks pretty white - it’s definitely not blue or yellow). And when connected through Coolterm, it starts to print out debugging lines in my firmware:

waiting 10 seconds before we publish
waiting 2 seconds before we publish
waiting 1 seconds before we publish
Requesting Weather!

“Requesting Weather!” is in my loop() method.

If I then do a factory reset (hold down both buttons, let go of only reset, wait for it to flash yellow, and then flash white, and then let go (usually around 6-10 seconds) completely of the buttons, it then blinks blue.

At this point I try and set it up with the app (or CLI), and it errors out on “Device Cloud Connection”.

I repeat all these steps over and over, and it’s consistent. This leads me to believe the factory reset just isn’t working. Any ideas?

I will try and report back