Fail to connect to Photon's Wi-Fi

I am unable to connect to the Photon chip’s WiFi either via iOS or the new web method on a PC. The chip’s SSID shows up, but connections to it fail. Further, using the USB method to setup WiFi, the setup appears to take but it never connects to the cloud (blinking green). I have tried the methods mentioned in previous posts but still no luck. Anything I am missing? I have had no issues connecting many other chips. Most posts similar to this ended up needing a new device.

particle --version
1.22.0

particle serial identify
Your device id is {removed}
Your system firmware version is 0.6.2

particle serial mac
Your device MAC address is {removed}

Setup WiFi via phone (iOS)

  • select Photon-KS2R for WiFi list
  • Unable to join the network “Photon-KS2R”

Setup WiFi via web

  • downloaded web page
  • tried switching PC WiFi to Photon-KS2R, but it never connects
  • web page always says “Waiting for you to connect to your Photon”

Setup WiFi via USB

  • particle setup
  • claim code obtained
  • scanned for an selected target network (WPA2, AES)
  • enter WiFi password
  • device restart and LED blinks green but never connects
  • “It doesn’t look like your Photon has made it to the cloud yet.”
  • “What would you like to do? Check again to see if the Photon has connected”

Updated CLI

  • npm update -g particle-cli

Updated Photon

  • particle update

Checked keys on device

  • particle keys server
  • particle keys doctor YOUR_DEVICE_ID

Do you mean it’s stuck on blinking green (without any other colors) or do you expect the device to end up blinking green (which is not cloud connected, but connecting to WiFi).

You could try particle serial wifi while the device is blinking blue and avoid any auto-detection magic and enter the SSID and encryption manually.

If this still doesn’t help, post a video of the device starting up and blinking away for about 30 sec

May this device ever have been set for static IP or external antenna?
If so, this needs to be undone via code before you can connect to a new network.
You might also need to wipe the current credentials by holding SETUP for 10+sec till you see rapid blue flashing.
Another reason might be too long SSID and/or password or exotic characters in them.
Have you tried connecting to any other network (e.g your phone’s hotspot)?

What does this mean? What OS are you using and how does it tell you that it doesn’t connect?

It’s stuck.

Tried that. The manual configuration is how I got as far as the blinking green light. It was the same result as going through the setup process.
I am out of the office for a while and don’t have the ability to video that device.

The device has never been set for anything and never programmed. It is fresh out of the box from Particle as part of a shipment of other devices for a training class. I’ve wiped the credentials (SETUP for 10sec) already as part of my trying to get it to work.

The SSID is good. I have connected many other chips to it. There seems to be an issue even before that as I can’t connect to the device when it is in access point mode for phone or web setup (described in original post).

That is referring to the new web page method connect on a Windows 10 machine. I tried switching the PC’s wireless connection to the Photon’s SSID while it’s in setup mode (blue blinking LED). Photon-KS2R is the SSID that shows up for the device. The PC shows “Connecting…” but never does.
When trying to connect to the device from iOS, it comes with the message “Unable to join the network “Photon-KS2R””.

For iOS this is a known issue, that it refuses to connect to a WiFi network that doesn’t also provider internet access on some devices.
But for Win that’s new to me.

Ok, so I’m not getting anywhere on this. The chip is broken out of the box. What’s the process for exchanging it?

Your device can probably be fixed without an exchange by using the CLI or DFU to put new system software on it directly over USB.

If you want to talk to official support, which could end up in an exchange, go here:

https://docs.particle.io/support/support-and-fulfillment/menu-base/

And put in the details of your issue, contact info, and hit send.

I have found that Photon’s of a certain vintage refuse the connect from my MacBook Pro and therefore I will try the DFU route. But a more recent Photon worked fine with the wWeb based setup. if this is generally true it would be great if the docs reflected that to avoid frustration.

For Info:
I had a similar issue on some of my old Photons still tucked in their case since I bought them but hadn’t had a chance to make use of them.
For some reason, I was able to recover the connection after re-issuing a new “key”. Go figure why that is!
Took me half a day to figure this out but thought I would share this personal observation if that can help anyone else.

I had issues connecting to Photon’s Wi-Fi with my MacBook but it worked from the phone app.