Photon could previously connect, cannot now

hello,

i have a particle.io photon board i got at last week’s Node PDX conference. it has previously connected, several times, to the wifi and the particle cloud just fine, no problems, at several different locations.

today, at a new wifi place, i tried connecting it again. this is a place with wifi that works just fine on my iPad, iPhone and Chromebook/Linux-variant. my iOS app didn’t see it, at all. the photon, when first plugged in, did a quick flashing green on the led an nothing else. if i try the reset into safemode (as @dmiddlecamp directed me to do — https://docs.particle.io/guide/getting-started/modes/photon/#safe-mode), and i can never get to magenta flashing mode, it just resets and begins flashing yellow. or, at least i “think” it’s flashing yellow, looks like a fast flashing combo of green, yellow & a bit of red to me. in the iOS

i have also tried all your troubleshooting steps, https://docs.particle.io/support/troubleshooting/common-issues/photon/ & https://docs.particle.io/support/troubleshooting/troubleshooting-tools/photon/ , and nothing seems to work to bring back into “breathing blue” flashing mode to connect it to the wifi and the particle cloud.

in a totally separate issue, i have filed a bug issue for your particle-cli, #262, about “particle setup” not working with USB connect on linux variant systems like mine, and have heard nothing back — https://github.com/spark/particle-cli/issues/262 . and it’s languished out there for a while and i’ve heard nothing back. any news on this?

please let me know on the above.

best,

— faddah
portland, oregon, u.s.a.

What exactly did the app not see, the photon or the AP? Mind you that the app can only detect the device when that’s in Listening mode (blinking blue).

If you’re seeing yellow, you’re probably holding on too long and have passed safe mode. It comes really quickly after releasing reset -almost immediately- and can thus be a bit hard to get. Try releasing as soon as you see any light.
In safe mode, it’ll try to connect to the network as well, which will most likely fail due to missing credentials.

“breathing blue flashing”… Which of the two is it, breathing or flashing? Breathing blue doesn’t exist (whereas there is breathing cyan), while flashing/blinking blue indicates listening mode, which is what you want to be in for setting credentials. Try holding the setup button for 10s until the LED starts blinking blue rapidly. If all goes well, that should erase all credentials, and land you back into listening mode.

What kind of network are you trying to connect to? Just because it works on other devices doesn’t mean it should work on the photon. Both iOS and laptop device will allow you to play fancy video games, should that then also be possible on the photon…? That said, I get your point, but some more info on the network is in order. Is it perhaps 5GHz, which works fine with laptops/phones but is not supported on the photon? Does it have a captive portal? Is it an enterprise network? Things like that are good to mention.

As far as the CLI issue goes, @jvanier might be interested in that since I know he’s been spending some time on the CLI lately.

For you CLI problem, do you get the same outcome when you follow this suggestion given by CLI?

so try

sudo particle setup

And for only setting credentials I’d rather go with

sudo particle serial wifi

for which you need to be in Listening Mode and don’t use the auto-scanning feature, rather do it manually.