[SOLVED]Blue flashing light but no wifi?

My photon was working fine until yesterday. But now it doesn’t seem to be able to connect to anything.

I turn it on, get a white light for ~1sec.
Then turns to flashing blue (which I assume means its waiting for me to connect using my phone app).
But in the particle app I cant see it listed.

Is it broken? Am I doing something wrong?

Blinking blue indicates listening mode. Try pressing “setup a photon” and follow the steps. That should work.

I click the “Set up a Photon” button.
That takes me to the “Time to set up your Photon!” page.
I click “Ready”, and get taken to the “Choose your Photon” page…

Where it says “(No Photon devices found)”

Could you try placing the photon in Safe Mode and see what that does?

Depending on what mobile OS you’re using, you’ll have to switch your wifi first. On iOS you’ll have to do so manually.

If you’ve got the CLI working, you can also use that. particle setup should allow you to connect it. A serial connection is also possible. With the CLI, you’d do Particle serial wifi, and with other serial clients, you’d press ‘w’ (if I’m not mistaken!)

This might also work if you have already flashed some new firmware using the Web IDE before: http://photonsoftap.meteor.com/

Thanks @Moors7 that worked perfectly.

I think the issue was bad application code. Specifically application code which is too long.

1 Like

Glad you got it working.
What exactly worked, for future reference?