Flashing blue immediately after setting WiFi

I had my photon working well in one WiFi environment, and I brought it to a new area to further test. I connected with the iOS particle app, selected a network and… the photon is still flashing blue, immediately after it confirmed the new network credentials.

When I try to connect from the iOS app, it says “offline”

Any advice?

Turn it off and back on again?

I have that happen when I change settings on my router. I’ve noticed it doesn’t retry once it goes into blue flashing mode. It just stops at the first error.

I tried resetting it a couple of times, no luck. I think the problem is that I am now at work in an enterprise WPA2 environment which requires both username and password. At home (the first wireless network), I have only password.

Is there a way to connect photon to this kind of network?

As stated in the docs, there are issues with enterprise networks which haven’t yet been worked out entirely. Hopefully support for this will come in the future.

1 Like