Flashing green no connection


I have a spark photon that was having some issues connecting to the wifi out of the box. Finally got it connected and it ran for a couple of days fine. Today when connecting it connects with pulsing cyan light for a couple of seconds then return to flashing green.and says it is offline in my Particle iOS app.
I tried reseting it with no luck.

Its connected to an apple router with WPS2-PSK.

Does anyone know why?

Oh and also, i cannot find the device in device manager in windows hasnt showed up there even after i tried a couple of online tutorials and multiple usb ports.


you should try updating your photon to the newest firmware to see if the issue still persists.

simplest way to do that is with putting the device into DFU-MODE
and then with the particle-cli issuing particle update and everything should be good.

The longer, manual instructions are referenced here https://docs.particle.io/support/troubleshooting/common-issues/photon/#manual-firmware-update