Flashing Green, Cyan, Red - Won't connect to WiFi

I have purchased a total of 8 Particle Photons. The last four arrived a few days ago.

Out of the first four, three connected to WiFi without issue. One was stubborn. It took working through the particle-cli to do a “particle update” and a wifi credentials reset and finally a particle serial wifi to get it connected.

I’ve got apps running on all four of this first lot, including interfaced to iOS apps pulling variables and accessing functions. All is well with the first four.

For the last four received last week:
Two connected to WiFi without issue.
One is DOA - neither LED lights up. Appears totally dead.
The fourth one has the persistent flashing green/cyan problem.

I’ve been through the flashing green posts and tried the suggestions. Still no joy. I have updated to 0.4.7, updated tinker and reset wifi credentials.

Here’s a ‘particle serial wifi’ session:

MikesMacBookPro:Downloads mmalpass$ particle serial wifi ? Should I scan for nearby Wi-Fi networks? Yes ? Select the Wi-Fi network with which you wish to connect your device: Malpass ? Should I try to auto-detect the wireless security type? Yes ? Wi-Fi Password: xxxxxxxx (<- have verified multiple times this password is right) Done! Your device should now restart. MikesMacBookPro:Downloads mmalpass$
Device does in fact restart. It flashes green for about a second. then flashes cyan for about a second, then flashes cyan quickly for about a second with the final few cyan flashes accompanied by the red component in the LED lighting up.

It cycles through this slow cyan, fast cyan, fast cyan with red.

Any ideas?

Thanks,
Mike

After posting, a suggested topic popped up that solved the issue.

Topic: Photon setup flashing cyan with a “quick red burst”

Scroll down to entry by mdma - Particle Senior Embedded Engineer