Photon stuck flashing cyan with orange bursts

Hi there. I have two photons working fine in my house, but a new third one is stuck flashing cyan rapidly–there aren’t any red flashes or orange flashes, it’s just stuck flashing cyan after I try to join it to a Wi-Fi network.

Since the other two photons are working fine, I don’t think the issue is with my home network. However, I’ve tried to connect the broken photon to two other networks using the particle CLI, and in both cases, the CLI Wi-Fi configuration command completes successfully, but the photon remains stuck flashing cyan–with what looks like an occasional set of orange or red flashes, as described here:

Just in case it’s a code problem, I went ahead and used the CLI to upload an empty program to the photon. I followed the recommended steps, the particle keys server and keys doctor commands to repair keys (both the device key and the server key) on the photon, but no luck.

I ran the CLI particle update command as well to update it to the most recent firmware. So far, I’m really at a loss for what to do next; I feel like I’ve followed most all of the relevant steps!

Has anyone else seen something similar, and if so, what worked for you?



Are you using particle setup to configure WiFi credentials?

Can you place it in Listening mode, hold on the MODE/SETUP button until it blinks blue rapidly to clear WiFi credentials and configure again.

Could you post a video of your exact RGB patterns - there are multiple codes that may sound the same in words but look different

Also try these steps

// in Listening Mode - to acquire the device ID
particle identify 
// in DFU Mode
particle keys server
particel keys doctor <yourAcquiredDeviceID>

But there are also other possible reasons for this

  • Your device may have been set up to use static IP some time earlier, and since this is a “sticky” setting, you’d need to flash some code that goes back to dynamic IP.
  • Your router might not have a free DHCP IP for the new device and hands out one that was previously used, but was considered stale, but once the original “owner” of that IP returns, the new one will lose it again.
  • bad WiFi connection due to distance, radio noise or a previous setup to use the external antenna (without one installed) instead of the chip antenna, which is also a sticky setting which needs to be set back explicitly

@kennethlimcp, the cyan state will only be reached after the device “joined” the WiFi network, so no issue with the WiFi creds IMHO.