Photon flashing cyan and blinking orange

Photon is alternating flashing cyan (fairly quickly) and blinking orange (slower) every few minutes, with occasional green flashing. I tried some things here (Photon setup flashing cyan with a “quick red burst” (now orange burst) [Solved]) and I was eventually able to claim it and got breathing cyan, but still don’t know what actually fixed it for me. Now it wont connect anymore, and is back to the cyan/orange cycle.

Any advice would be greatly appreciated.

Thanks

What was the code running before this occurred?

Not sure what you mean by this, do you mean how did it get to be flashing in this way?

If so I just put it in listening mode and attempted to connect to wi-fi using particle serial wi-fi. This network is the same one I successfully connected to before.

Yup, wondering what is running that caused the Photon to end up in this state. Orange (red/yellow) refers to bad keys and that shouldn’t happen twice in a row.

The fix would be to use particle keys doctor DEVICE_ID_HERE in DFU mode. This will generate a new set of keys, DFU the private key to the Photon and send the public key to the :particle: :cloud:. That’s the fix.

I have tried this before, could you sent me a specific list of commands so that I am sure I am doing it properly?

Thanks for the prompt responses.

The command is as per the above but i can be more specific.

  • Place the device in Listening mode (blinking blue)
  • particle serial identify (to get the device ID)
  • Place the device in DFU mode (blinking yellow)
  • particle keys doctor PASTE_DEVICE_ID_HERE
  • hit the Reset button and the Photon should connect properly
1 Like

Just did this and the command seemed to work, but now the device is back to doing the exact same thing as before.

Can you place it in safe mode instead?

How do I do this? I tried Holding both buttons and releasing the reset button, the releasing the setup button when is flashes magenta. It goes white for a second, then back to what it was doing before. I cant seem to get it breathing magenta.

Weird… Can you place it in DFU mode and run particle flash --usb tinker and see if it works?

Were they any error when performing the keys command?

Here’s what happened while running the particle keys doctor command:

**particle serial identify**

Your device id is <>
Your system firmware version is 0.4.9


**particle keys doctor 3e003a001347343338333633**
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -l
Found DFU device 2b04:d006
running openssl genrsa -out 3e003a001347343338333633_rsa_new.pem 1024
running openssl rsa -in 3e003a001347343338333633_rsa_new.pem -pubout -out 3e003
001347343338333633_rsa_new.pub.pem
running openssl rsa -in 3e003a001347343338333633_rsa_new.pem -outform DER -out
e003a001347343338333633_rsa_new.der
New Key Created!
running dfu-util -l
Found DFU device 2b04:d006
This file already exists, please specify a different file, or use the --force f
ag.
Continuing...
checking file 3e003a0013433633_rsa_new.der
spawning dfu-util -d 2b04:d006 -a 1 -i 0 -s 34:leave -D 3e003a001333363
_rsa_new.der
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #1 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "DCT Flash   "
Downloading to address = 0x00000022, size = 610
Download        [=========================] 100%          610 bytes
Download done.
File downloaded successfully
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Saved!
running openssl rsa -inform PEM -in 3e003a00134734333_rsa_new.pub.pem -p
bout -outform PEM -out C:\Users\akato\AppData\Local\Temp\116228-6304-1ndk1ln.pu
.pem
running openssl rsa -pubin -inform PEM -in 3e003a00333633_rsa_new.pub
pem -pubout -outform PEM -out C:\Users\akato\AppData\Local\Temp\116228-6304-1nd
1ln.pub.pem
attempting to add a new public key for device 3e003a00134734
submitting public key succeeded!
Okay!  New keys in place, your device should restart.

I ran particle flash --usb tinker in DFU mode and it seemed to work successfully, but I see no change.

Can you delete the previously created key files in the directory and try again? or you can use particle keys doctor deviceID_HERE --force

Ran particle keys doctor device_ID --force and it is now back to the same cycle

Any Ideas?

@Ak4, no clue what’s going on with your device. Has it been claimed before? Can you show a video of the led light sequence?

Its been claimed. Heres the cycle it keeps repeating:

That is not the red/orange burst but this error (is it orange or red?)
https://docs.particle.io/support/troubleshooting/troubleshooting-support/photon/#error-codes

1 Like

Definitely Orange. Will flash orange 3 times in between cyan and green flashing. Sometimes a few minutes go by before I see the orange again.

Never seen a pattern like that with orange. It looks more like unable to connect to the :cloud: successfully.

Can you setup a mobile hotspot, configure the photon to use that and see if connection is successful?

My phone wont connect. Goes through the motions but gives me an error message that says “Setup process couldn’t configure the Wi-Fi credentials for your photon, please try running setup again after resetting your Photon and…”