Photons keep flashing cyan and orange even after particle keys doctor

Since yesterday, all 4 Photons and a Core in my household have stopped connecting. I resetted them, resetted the router and modem but they won’t connect. They keep flashing cyan with the occasional 3 flashes of orange. I have tried connecting one of them through another internet connection/provider (wifi tether) but it did not work either, excluding problems with my network.

I have flashed tinker using ‘particle flash --usb tinker’ through DFU and I have also run particle keys doctor with the following result:

C:\Users???>particle keys doctor ???
New Key Created!
Saved!
Saved!
attempting to add a new public key for device ???
submitting public key succeeded!
Okay! New keys in place, your device should restart.

I tried setting the wifi credentials again, and this resulted in the application going through all the steps and stopping in the “checking connectivity” stage. The led is now blinking cyan (on the device I am testing on).

My Particle account seems to be fine since I can connect to the console without problems (using 2FA).

I find it odd that all 5 devices decided to stop working simultaneously.

UPDATE: It appears that when I try to connect through a different internet service provider (I tried with another two) it works fine (contrary to what was stated earlier. However, when I tried connecting through a different network but same ISP as my own (Melita) the cloud connection fails. Is it possible that the ISP all of a sudden started blocking access to the particle cloud servers? Is there anything specific that I need to have them check? Up until they were blaming my router, which is clearly not the case since I had the same problem with someone else’s Melita modem. So I need to give them all the information they might need to pinpoint the choke point.

UPDATE - The devices started working again on their own this morning. I guess the ISP realized what they did when the problem started and fixed it.

3 orange blinks is a communication error, not a keys error. The most common cause is a firewall that is blocking TCP port 5683 (CoAP) outbound. The other is that a captive portal is redirecting DNS to device.spark.io to a network terms of service page.

  • 1 orange blink: Decryption error.
  • 2 orange blinks: Could not reach the internet.
  • 3 orange blinks: Connected to the internet, but could not reach the Particle Device Cloud (This sometimes is seen as yellow or red and indicates bad server keys).
  • 1 magenta blink: Authentication error.
  • 1 red blink: generic handshake error (device could have the wrong keys or has just encountered a generic error in the handshake process)

Also:
https://docs.particle.io/tutorials/device-cloud/introduction/#cloud-services-and-firewalls

1 Like

From what I could gather, to open the port for my devices I need to know which internal IP address they are using. Is there a CLI command that would give me that information?

The port could be any of the ones in this list. It varies with each cloud connection attempt.

Hi,
I meant the internal IP address (192.168.0…)
I am still not sure I actually need it because I am not sure how to open a port on a TP-Link Router.

I have run:

particle keys server
particle keys doctor YOUR_DEVICE_ID

but I still cannot get it to connect to the cloud. The furthest I can get when attempting to re-enter the wifi credentials is “checking internet connectivity”.