Continuous blinking blue

I’m using a Photon which is connected to some sensors. I had a strange experience and I’m trying to figure out the cause. For weeks, this Photon has been running continuously, breathing cyan. Then a couple of days ago it starts flashing dark blue. I power it on and off, but to no avail. I try to restore wi-fi credentials using the iOS App. It gets stuck while doing so and gives me an error saying something like ‘it cannot release the wi-fi network.’ I think it meant that when trying to configure the Photon using the Wi-Fi app, once the credentials are supplied it remains connected to the Photon instead of switching back to the main wifi. I tried this a couple of times with the same result.

Then I thought of updating the firmware again. I removed the power supply from the wall and connected the Photon to my computer using the USB. When it powered up again, it blinked green and then the cyan breathing was on again. It was transmitting data as if nothing was wrong in the first place. I connected it back to the power outlet. The cyan breathing resumed. Everything seems fine.

I’m not quite sure what went wrong in the first place, or how it was fixed. Has anyone else had a similar experience? Any way to make sure this doesn’t happen again?


I last updated the firmware in September, so I think I have 4.5 on the Photon.

Hi @saran,

Hmm, blinking blue is the photon going back into setup / listening mode because it couldn’t find the Wifi network for some reason. It sounds like it stayed in this mode instead of retrying the list of known networks again, and needed to be reset. Does that sound right?


Yes, that’s correct.

I couldn’t figure out the issue. And I had to update the firmware to the latest version anyway. So I did the update. Everything seems to be running fine now.

1 Like