After a power failure, Photon can't connect to wifi, flashing blue

SECOND EDIT: SOLVED. See bottom. But I’ll leave this up for future googlers.

EDIT: I just tried doing the TEN second hold of the setup button and then re-adding the device in the Photon app - now it starts up, flashes green, flashes cyan, then blinks RED once, then flashes cyan, and endlessly repeats this cycle of flashing CYAN with one red blink in between. This happens whether I try to start it in safe mode or not. I have no idea what’s going on at this point, but I’m pretty sure the wifi chip isn’t fried since I can at least talk to it with the app.

This is where I’m at now:

The power went out at my house for about 2 hours. When it came back on, ONE of my photon’s wouldn’t reconnect (I have one indoors one outdoors acting as weather sensors - the one outdoors reconnected just fine, but the indoor one refuses to). It just sits there flashing blue (dark blue, not cyan). I tried holding down the setup button for 3 seconds to put it in listening mode, then I launched the app on my phone, added a new device (since it just refused to see the existing already named device), it found the Photon’s wifi hotspot, I told it what my home’s wifi SSID and password is, then I saw the photon flash green…

…aaaand back to flashing blue. I’m really at a loss here as to why this would happen at all, any suggestions as to what I could do? It’s been working fine for months. Pretty sure it isn’t a power surge issue, every other device in my house is fine, and after all it was being powered by a wall wart USB adapter, not straight 110v.

So I found someone else who got stuck at “flashing cyan and blue”, here:

I followed the instructions. Downloaded the Particle CLI installer, it installed flawlessly. Or so I thought, apparently it didn’t install an OpenSSL, I had to go find one manually, then manually move it to the system32 folder.

But I did that. And then I was finally able to run the command:

C:\Windows\system32>particle keys doctor 21003a000151343530343432
Found DFU device 2b04:d006
Found DFU device 2b04:d006
New Key Created!
I couldn't find the file: 21003a000151343530343432_rsa_new.der
Make sure your device is in DFU mode (blinking yellow), and that your computer i
s online.
Error - I couldn't find the file: 21003a000151343530343432_rsa_new.der


I have no idea what any of this means, it says new key created, but then it can’t find the key it just created?!

and FINALLY figured it out. The reason the particle keys doctor command wasn’t working, was because I was in system32. Apparently as soon as I cd… out of that folder, it works just fine. And as soon as I ran that command, my particle was back to the way it was before. Didn’t even need to run the other two suggested commands, the “particle keys server” and “particle flash --usb tinker”. So I’ll leave that little hint for future googlers.

For the Particle team: Apparently the firmware has a bug in it that will cause it to get stuck in listening mode after a power interruption. Once this happens, the only way to fix it is using the command line tools.

Also, your Particle CLI installer doesn’t install OpenSSL on Windows. I don’t know if it’s supposed to, but it just wasn’t there, at all.