[SOLVED] Can't connect to Wifi/Cloud


I’ve a Problem connecting my Photon to Wifi/Cloud. I tried by the iPhone app, as well as the terminal.
My device was claimed to another account, but my classmate said, the already unclaimed it.

  • turn into listening mode (blue)
  • $ particle setup
    result: photon is blinking green

productname: mac os x
productversion: 10.11.6
buildversion: 15g1004


setup is easy! let's get started...
it appears as though you are already logged in as xxxxx@xxxxx.com
> ? would you like to log in with a different account? no

> ! protip: hold the mode/setup button on your device until it blinks blue!
> ! protip: please make sure you are connected to the internet.

i have detected a photon connected via usb.
> ? would you like to continue with this one? yes
> ! the photon supports secure wi-fi setup. we'll try that first.

> ! protip: wireless setup of photons works like a wizard!
> ! protip: we will automagically change the wi-fi network to which your computer is connected.
> ! protip: you will lose your connection to the internet periodically.

> ? found "photon-c6km". would you like to perform setup on this one now? yes

> ! protip: you will need to know the password for your wi-fi network (if any) to proceed.
> ! protip: you can press ctrl + c to quit setup at any time.

obtained magical secure claim code.

hey! we successfully connected to photon-c6km

now to configure our precious photon-c6km

> ! protip: if you want to skip scanning>
> <or your network is configured as a
> ! protip: non-broadcast network>
> <please enter manual mode to proceed...

> ? would you like to manually enter your wi-fi network configuration? yes
> ? please enter the ssid of your wi-fi network: NameOfNetwork
> ? please select the security used by your wi-fi network: wpa2
> ? please enter your wi-fi network password: ****
here's what we're going to send to the photon:

wi-fi network: NameOfNetwork
security: wpa2
password: ****

> ? would you like to continue with the information shown above? yes

obtaining device information...
setting up device id 3xxxxxxx8
requesting public key from the device...
setting the magical cloud claim code...
telling the photon to apply your wi-fi configuration...
the photon will now attempt to connect to your wi-fi network...

configuration complete! you've just won the internet!
> ? would you like to return this computer to the wireless network you just configured? yes
> ! it doesn't look like your photon has made it to the cloud yet.

> ? what would you like to do? check again to see if the photon has connected
> ! it doesn't look like your photon has made it to the cloud yet.>

Try placing it in DFU mode and doing particle update, and then once more with particle flash --usb tinker. That might help :smile:

Same error! :confused:

Is it showing any other colors, or green only?

Can you try to set the WiFi credentials via particle serial wifi instead?

Claiming the device (if still required can be done in a seperate step)

Listening mode => blue
connecting to wifi => green

App and terminal.

DFU and particle serial wifi don’t work

Sure not, particle serial wifi is meant to be executed in Listening Mode.
BTW, have you wiped all the previous WiFi credentials via holding SETUP 10+ seconds till rapid blue blinking?

Do you mean you have already tried a serial terminal program too (e.g. PuTTY, coolterm) with the w command?

  1. Plugged in to USB port
  2. holding down SETUP 10 sec +
  3. opening iTerm
  4. $ particle serial wifi
  5. enter SIDD, WPA2, PWD
    -> blinking green

  1. Plugged in to USB port
  2. holding down SETUP 10 sec +
  3. opening iTerm
  4. $ particle setup
  5. step by step
    -> blinking green

  1. opening CoolTerm
  2. Setting up
  3. connect
  4. press w
  5. enter SIDD, WPA2, PWD
    -> blinking green

Hmm, could it be that your mate had set the device to use the external antenna and/or static IP?

If so, just flash this simple sketch to revert to normal via USB


void setup()
  pinMode(D7, OUTPUT);
  digitalWrite(D7, HIGH);

void loop()
  digitalWrite(D7, !digitalRead(D7));

Where should I do this?

You can copy this code to a text file, name it something.ino, put it in an empty folder, navigate to this folder in your terminal and run

particle compile photon something.ino

this should provide you with a .bin file to flash via

particle flash --usb whatever.bin

Or you could copy that code to Particle Build Web IDE compile it there and download the binary via the :cloud: icon next to the app name.
Then flash as shown above.

Web IDE can’t work because my devices isn’t claimed.

Compiling code for photon

attempting to compile firmware
Compile failed. Exiting.
photon.cpp:1:7: error: expected constructor, destructor, or type conversion before '(' token

make[1]: *** [../build/target/user/platform-6photon.o] Error 1
make: *** [user] Error 2

// EDIT:
Now, flashing the devices worked. But setup the photon results in blinking green!

// EDIT 2:
"> Obtaining device information…" since about 5 minutes

still, any ideas?

Says who?

I see, you have no other devices either - that explains why :wink:

About your error message, this is what I get with the code from above (with CLI v1.16.0)

C:\Temp\dmy>particle compile photon dmy.ino

Compiling code for photon

attempting to compile firmware
downloading binary from: /v1/binaries/57dd62540d7a7e4f5e8da63b
saving to: photon_firmware_1474126418036.bin
Memory use:
   text    data     bss     dec     hex filename
   4380       8     596    4984    1378
Compile succeeded.
Saved firmware to: C:\Temp\dmy\photon_firmware_1474126418036.bin

What did the blue LED do when running this code?

Just to clarify some points:

  • you have already tried with another WiFi network?
  • you have also tried an open network?
  • your WiFi is not 5GHz?
  • your WiFi doesn’t use a channel beyond 11?
  • you have not got a MAC filter on your WiFi?

Using my iPhone (personal hotspot) as WLAN works… Now the Photon is cyan and D7 is blinking.

? What would you like to do? Check again to see if the Photon has connected
! It doesn’t look like your Photon has made it to the cloud yet.

Now I’ve to figure out why my router configuration doesn’t work.

OK, that’s a good sign that the device is functional.
I’d now try to claim it manually while connected to that hotspot.

For that you’d need to get the device ID from it (which you already should have from your previsous trials without success ;-))
But getting it via particle serial identify (in Listening blinking blue mode) should bring it up again.
Then take this device ID into this command (while breathing cyan)

particle device add <yourDeviceID>

after that you should also see the device in Build.

Once that’s done, we can try to track down the reason why your home WiFi won’t accept the device.

1 Like

Thanks a lot! Now it works on my home WiFi, too!

1 Like

Good to know and have fun with it (after a bumpy start) :+1:

Can we mark this as solved then?