Photon Setup Difficulties - No Photon Recognised in CLI Setup

Hi, I recently bought a Photon and have had difficulty in getting started/photon connected.
I have the CLI working and have run “particle setup” with photon connected by USB and blinking blue.
The following is the response I get from the particle CLI:

                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |

> Setup is easy! Let's get started...
> It appears as though you are already logged in as {email}
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You will lose your connection to the internet periodically.

> No nearby Photons detected. Try the `particle.js help` command for more information.
? Would you like to wait and monitor for Photons entering setup mode? (Y/n)  N

> Ok, bye! Don't forget `particle.js help` if you're stuck! <3

========================================
All of this time the photon remains blinking blue.
I read a few other threads on wifi issues etc. so I have tried setting up my cell phone hotspot and re-running setup, but no change to the outcome of the above.

My wifi setup is a Billion ADSL router (wifi disabled) cabled to an ASUS RT-AC68U 802.11AC which I think has both 2.4 and 5GHz bands.

Any help welcomed. Thanks.

Instead of Particle setup could you try particle serial wifi?

Your 2.4GHz network should have a different SSID as your 5GHz or disable 5GHz (for the setup).
The Photon only supports 2.4GHz 802.11b,g,n (your ac router needs to be g,n compatible)

Thanks @ScruffR for the advice. I’ve been away a while, now back to it. I disabled the wireless access point’s (ASUS RT-AC68U) 5GHz radio as you suggested (only the 2.4GHz working), Re-ran “particle setup” and got the same response as I posted above. “No nearby Photons detected.”, I have a second photon so tried it. Same result. Both were blinking blue through the whole thing, connected by USB. I’ll try @Moors7 suggestion now and will report back on that in a separate reply. I appreciate your help. Thanks again.

Thanks @Moors7. That worked! At least to the point where the photon was breathing cyan (connected!).
It restarted and went through a fast and slow green flash then to breathing cyan.
But the photon isnt showing on my dashboard or in particle phone app.
I assume because the ‘particle serial wifi’ command doesn’t seem to know/prompt for my login details (like ‘particle setup’ does), it doesn’t know that the photon belongs to me.
Is that right?
Based on a forum search for my next step I tried ‘particle identify’ and got this response:

particle identify
"Your device id is 4200…3033
Your system firmware version is 0.4.9"

I tried particle device add (in listening mode) but it failed.
“Claiming device light_sabre
Failed to claim device, server said: [object Object]”

Any help appreciated.

You’re very close! particle device add xxxxx must be done when the Photon is breathing cyan.

Just to make sure we are on the same page, if you want to scan for a nearby Photon via CLI on your computer, the computer itself must have a WiFi card installed to scan for the Photon, you can’t use the router for you to scan for it.

Thanks @rickkas7. I just found that too browsing for answers. I tried it, but got same result.
“particle device add light_sabre
Claiming device light_sabre
Failed to claim device, server said: [object Object]”

The overall sequence in this has been:

  1. Tried to setup with Android app - failed.
  2. Tried to “particle setup” with CLI - failed, photon not recognised on wifi (both 5GHz running & not running).
  3. Tried “particle serial wifi” - worked fine, photon breathing cyan, but not visible on dashboard.

Sorry, particle device add takes a device ID as the parameter, not the device name. I should have put that in there instead of xxxxx.

1 Like

Thanks @ScruffR. OK, understood. Yes I’m using laptop via wifi to router.

Could you try particle list and see if your device is seen there?

And you would not use particle device add light_sabre but particle device add <your long number device ID here>

the long number you posted above

Thanks to you both @Scruffr and @rickkas7. It worked!! … particle device add {device ID #}.
Got it. You guys are great. Thanks for taking the time to help me and so many others …

2 Likes