Can't Install Photon USB Driver in Windows Vista

I can definitely appreciate how much a PITA vista is :wink: Hope this helps

3 Likes

Thanks for those steps. I tried all you said but when I got to install the driver I get this error consistently.

I’ve googled it exhaustively but have no idea what’s going on.

Hmm, ok maybe try this… remove the driver completely if anything has installed and then instead of installing the Communications Driver first…

When you get to this step:

Click HAVE DISK and follow that through to the Photon driver.

BDub, tried that too, similar result. :frowning:

Btw, the whole reason I’m trying to install these drivers is I need to reflash the Photon since the one I received yesterday in my order was obviously shipped with bad (old) firmware. I discovered this through reading old posts of others’ experience.

If I’m on the wrong track as how to do this please advise.

btw, thanks for your help, much appreciated.

and

and

Sure, @kennethlimcp and I are only members in this forum and not a reputated Particle employee, but I’d say this still stands.
At least when you have troubles with serial.

If you had bothered to accept this route and asked how to get these drivers (although described in the linked thread), you might have gotten a link to zadig

1 Like

Ok, ScruffR, I re-read your post and followed the instructions in the link. Installed DFU and zadiq, etc. I already had node.js and particle installed. I uploaded the firmware. And tehn I went back to my Android app to try and run Get Started. Again it fails after several seconds after I give the Wifi credentials, and the message "Uh Oh! Setup process couldn’t disconnect from the Photon Wi-Fi network. This is an internal problem with the device. … "

Any suggestions? Was I shipped a dud device?

thanks again

After resetting the device several times, I now find it “hanging” at the point in the Android app “Waiting for device cloud connection.”

Then after a minute I get an Error, 'Setup process couldn’t configure the Wi-Fi credentials for your Photon, please try running setup again etc ect"

You can flash individual binaries over serial now with the CLI:
particle flash --serial firmware.bin

@allegrojm With your device in DFU mode, if you run dfu-util -l what do you see as output?

This is what I see

Yup, but serial is obviously not working :wink:

@allegrojm, you said you wanted to update your device but then you didn’t or did you?

I stated above that I uploaded the firmware. And I pasted a screenshot. Did you not see that?

Just mentioning another way to update firmware is all :wink:

Yep! We are all talking to each other now and missed that :wink:

So that’s interesting… please try the more manual way of entering credentials:

  • Place Photon in Listening Mode (blinking blue) and keep holding SETUP for 10 second to erase all credentials
  • run particle serial wifi
  • enter credentials and see if it connects
  • if not press reset and wait to see what it does

But that ain’t going to work if I cab’t install the USB driver, right?

My bad - I obviously read over that bit - sorry :blush:

And I got stuck on the particle login mistaking it for particle setup so I ignored the “blurb” that usually comes with it :wink:

BTW: I just dug up an old Vista machine and will try to duplicate your serial driver issues.

No problem - I know these posts get chatty. I think the only way I’m going to start to make progress is if I can figure out how to get the serial port (usb) driver installed. I continue to scour for a solution. Now every time I try and install the Photon USB driver I get

That does in deed look bodged.

Maybe something got jammed at some point.

Maybe you need to remove all drivers previously tried.
For that you might need to create a environment variable DEVMGR_SHOW_NONPRESENT_DEVICES set its value to 1and restart Windows.
Then go back to DevMgr and tick View - Show hidden devices and delete/uninstall anything that might be in connection with the Photon Com Port (not the DFU drivers tho’).

Then restart and try again.


http://websistent.com/windows-devmgr_show_nonpresent_devices/

Yes that is a problem… however there is another workaround you can try. Entering your credentials manually in an app, and flashing that app over DFU USB.

WiFi.setCredentials() Test App

#include "application.h"

SYSTEM_MODE(SEMI_AUTOMATIC);

void setup() {
	// for hidden and offline networks on the Photon, the security cipher is also needed
	// Security options are: WEP, WPA, WPA2
	// Cipher options are: WLAN_CIPHER_AES, WLAN_CIPHER_TKIP and WLAN_CIPHER_AES_TKIP
	Serial.begin(9600);
	Serial.printlnf("hasCredentials?: %s", (WiFi.hasCredentials())?"yes":"no");
	WiFi.on(); // turn on module, or creds will not be saved
	WiFi.setCredentials("myssid", "mypassword", WPA2, WLAN_CIPHER_AES);
	WiFiAccessPoint ap[5];
	int found = WiFi.getCredentials(ap, 5);
	Serial.printlnf("Stored Credentials: %d", found);
	for (int i = 0; i < found; i++) {
	    Serial.print("ssid: ");
	    Serial.println(ap[i].ssid);
	    // security is one of WLAN_SEC_UNSEC, WLAN_SEC_WEP, WLAN_SEC_WPA, WLAN_SEC_WPA2
	    Serial.print("security: ");
	    Serial.println(ap[i].security);
	    // cipher is one of WLAN_CIPHER_AES, WLAN_CIPHER_TKIP, WLAN_CIPHER_AES_TKIP
	    Serial.print("cipher: ");
	    Serial.println(ap[i].cipher);
	}
	Serial.printlnf("hasCredentials?: %s", (WiFi.hasCredentials())?"yes":"no");
	Particle.connect();
}

After you connect, your credentials will be saved in non-volatile memory so you won’t need to include this code every time.

1 Like

Ok, here is an update. After screwing around with trying to install/uninstall/reinstall the Photon USB driver, I enabled verbose logging in the SetupAPI Loglevel and discovered some weirdness where the windows setup was trying to copy the usbser/serenum.sys driver files from the c:\windows\inf directory or else the c:\windows\system32\driverstore\filerepository\photon.inf_“whatever” directory - which one depending on whether update or re-install driver was being used. The key to debugging this was “file not found” each time the install failed.

I suspect the behavior I’ve been experiencing is related to how the Photon INF file interacts with the Vista device install process (I was looking at include=mdmcpq.inf, but lost interest), at least on my machine.

I copied those 2 drivers to the c:\windows\system32\driverstore\filerepository\photon.inf_“whatever”
directory and performed a “Re-install drive” and lo and behold it worked. See screenshots:

And now I can run particle:

Thanks for all the help so far from all. Next step is to try and get the device working. Look for another troubleshooting topic coming your way soon … :slight_smile:

3 Likes

Glad to hear it @allegrojm thanks for being persistent!

I’d like to document this fix as a note for Vista users, in case this pops up again. After you copied the files, I’m thinking that instead of “Re-install drive” you mean right-click on the device and “Update Driver Software…”? If so did you let it “Search Automatically for Updated Driver Software” then?

Yeah, the good news is I got the USB working but my frustration with this thing continues, See Multiple Issues Trying to get First Photon Connected for my continued travails.

As far as what I did to get the USB working, after I copied the files I did do a Re-install driver and not Update driver, and I did do a Browse for the Photon USB driver to where I had unzipped it.

Through trial and error and reviewing the SetupAPI and SetupAPIDev logs I figured the setup behavior (code flow) was different in that the the Update Driver way of doing it would not work correctly i.e. it would not find usbser and serenum files correctly I seem to recall.

When a device is first installed, a directory is created in c:\windows\system32\driverstore\filerepository\ and all the driver’s files are copied there, so a subsequent re-install will retrieve the files from there. So when I copied the files and did a re-install, it picked up the files correctly from there where I copied them. I believe the Update driver will behave similarly to an original Install process (in that it will look for the driver files in the c:\windows\inf directory) and fail. So by doing the Install process first, and letting it fail with “can’t find file” or whatever the message was, and then copying the drivers from the c:\windows\system32\drivers to the c:\windows\system32\driverstore\filerepository\photon.inf_“whatever” directory and doing a re-install got it working for me.

Maybe copying the files to c:\windows\inf might have worked for the Install or Update process but I didn’t want driver files in a location they shouldn’t be.

These are my recollections of a pretty messy affair, but if you or someone else with this issue (on Vista or any other version of windows should it be the same issue) wants to test this, I’d recommend turning on the setup api loglevel to it’s most verbose level. See here https://msdn.microsoft.com/en-us/library/windows/hardware/ff550845(v=vs.85).aspx

1 Like