Particle app cannot setup Photon

Just downloaded Particle app and tried to connect to brand new Photon. App find Photon but does not find a WiFi network! When I type the name it seems it finds it because I see “secured with WPA2” beside its name in password step. So I manually added my network credentials, but I saw error sign on the app.

I checked my Android phone setup, when phone connects to Particle, it disconnects from my home network. I went settimg and selected my wifi network and pressed rescan button on the app but it did not find my network again. So again I manually added my network credentials, went back to setting and connected WiFi to Photon, and it wen tthrough the first 2 steps but again I saw error sign on the app.
Any advice to make the app work?

I tried again by manually setting up wifi, at the end it cannot claim ownership of my device and Photon blinks blue.

I tried CLI and I get these errors!

I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We’ll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer
is connected.
! PROTIP: You will lose your connection to the internet periodically.

Potentially unhandled rejection [2] Unable to find mac address in response (WARN
ING: non-Error used)

No nearby Photons detected. Try the particle.js help command for more inform
ation.
? Would you like to wait and monitor for Photons entering setup mode? (Y/n)

I tried putty too. photon gives me its id. I entered it in web ide but it replies “cannot claim core”

**Using CLI, another failure :tired_face: **

C:\Users\Amir>particle identify

Your device id is 210027000647343232363230

C:\Users\Amir>particle device add
Please specify a device id

C:\Users\Amir>particle device add 210027000647343232363230
Claiming device 210027000647343232363230
Failed to claim device, server said { ok: false, errors: [ ‘device does not exi
st’ ] }

Has it been connected yet (at least once)? Could you try particle setup wifi in the CLI when it’s in blinking blue/listening mode? Then don’t have it detect your security type automatically.

Photon has not ever been claimed.I did what you suggested, At the end it did not restart. I pushed reset button. Now it’s blinking orange :weary:

C:\Users\Amir>particle setup wifi
? Should I scan for nearby Wi-Fi networks? (Y/n) y
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: (Use arro
? Select the Wi-Fi network with which you wish to connect your device: ATT241
? Should I try to auto-detect the wireless security type? No
? Security Type: WPA2
? Wi-Fi Password: 8561898849
Attempting to configure Wi-Fi on COM5
I said: w
Serial said: SSID:
I said: ATT241

Serial said: ATT241
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2:
I said: 3

Serial said: 3
Password:
I said: 8561898849

Serial said: 8561898849
Thanks! Wait while I save those credentials...
Done! Your device should now restart.

I tried again, At the end it was blinking blue. I pushed reset button. Now it’s blinking orange :cry:

I setup another Photon with Android app. It went like a breeze. There’s something wrong with my first Photon. Maybe its id is not defined in the system. Any ideas?

Hmm, let’s call in @kennethlimcp on this one. It’s sounds like it could be a keys issue.

So it is blinking orange? or yellow?

This is the picture of Photon flashing

I have had the same problem and was solving it with Particle engineers. However unsuccessfully and at the end of the day they gave it up and suddenly stopped communicate. Now I have one Photon working and one as a draff.

@kennethlimcp Do you have any idea to revive this Photon? You’re my last hope. :disappointed_relieved:

@Amir,

Can you use DFU-util to flash V0.4.3 system firmware and let me know what colour does the RGB led show?

@kennethlimcp I flashed the last FW successfully. Then tried to install Tinker and got this error:

C:\Users\Amir>particle flash --usb tinker-0.4.4-photon.bin
Found DFU device 2b04:d006
checking file  tinker-0.4.4-photon.bin
spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D tinker-0.4.4-pho
ton.bin
dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 4740
Download        [=========================] 100%         4740 bytes
Download done.
File downloaded successfully
Error during download get_status

Error writing firmware...

I used app. It went through the first 4 steps smoothly but error showed at the last step. :anguished:

That is a known bug in DFU-UTIL, but your firmware should have flashed successfully, nothing to worry about.

1 Like

@Moors7 BUT STILL PHOTON DOES NOT SETUP WITH APP : “…could’t claim your Photon!” :rage:
Photon is still blinking blue. Any advice?

With the CLI, could you try particle setup wifi? Don’t have it detect your security type automatically.

I don’t think issue is related to WiFi because when I use app it stuck at CLAIMING Photon only.
Anyway I got a new error when using CLI: " Serial! no device available via serial"
I reset photon, restart Windows bit still the same issue.

I tried “Particle Setup” it says no usb connected!