Photon Setup Failed at "Verify Product Ownership"

Using the IOS app, it configures, connects to wi-fi, but fails at the Ownership step. I assume this is the same as the Claim Device via USB. With the IOS app the Photon is left flashing green. I’ve reset it a number of times - same problem.

I then loaded Node.js and tried the terminal USB connect method. Here is what I get:

[ ~/.particle ] particle cloud claim 260042000347343337373738
Claiming device 260042000347343337373738
Failed to claim device, server said  { ok: false, errors: [ 'device does not exist' ] }
[ ~/.particle ] 
[ ~/.particle ] more particle.config.json 
{
  "access_token": "xxxxxxxxxxx",
  "username": "---@------.com"
}

I —'ed out the email for obvious reasons.

Any ideas? I’ve tried several different power sources and tried both with an external u.fl antenna and without one.

I’m stuck.

Hey @TogaDriver,

A flashing green LED means it cannot connect to your Wi-Fi network. Can you double check the wireless network SSID and password? You can also go through the same setup process as the iPhone using the particle setup CLI command.

1 Like

Hi @TogaDriver

The device ID is a hex string with 0-9 and a-f but yours has no a-f nibbles and the odds are against that. You might want to just check it again and see if the “6” is really a “b” or something like that?

As @bryce said that is separate from the flashing green issue.

@bko @TogaDriver I actually checked the device id and it is valid. Probability, yay!

1 Like

Hi Bryce,
I used “particle identify” to get the ID via CLI so I kind of thought that would be correct. :smile:

So, flashing green means no wifi even though the IOS app says it connected? What did it connect to?

Is there any way to run the CLI in debug or verbose mode so I can get some log output while trying to claim? Short of taking encryption off my network wifi I’m currently sure I’m on the right SSID and am using the correct password. If flashing green means no wifi then I’m still stumped. the CLI seems to only leave particle.config.json lying around and no other obvious log files.

Here’s the weirdness I get trying to run particle setup:

Potentially unhandled rejection [2] Unable to find mac address in response (WARNING: non-Error used)

and

! Woops. Something went wrong connecting to Photon-T2GB. Please manually re-connect to your Wi-Fi network.

By going the “particle serial wifi” config route I was able to get the photon on my wifi. It looks to me like the attempt to automatically setup using Secure Wi-Fi Setup fails but a more manual approach works.

My photon is pulsing blue and I’ve confirmed its on my wifi devices list on my router (MAC matches). My router is a WNDR4500 and both 2.4 and 5 gig are configure for WiFi Protected Setup and have different SSID names.

Sounds like both the IOS app and the particle setup CLI are failing with this router unless I use particle serial wifi.

Hope this helps you debug the problem. Let me know if you’d like me to try some other paths to help isolate it.

Hmm. It sounds like something is going wrong with SoftAP setup. That is where the phone/computer connects directly to the Photon to send it the wifi credentials and also a claim code. I don’t think we currently have a more manual process than using the iOS app or particle setup.

I wonder if somehow the security type of your network is getting detected improperly during SoftAP. particle serial wifi only requires you to select between Unprotected, WEP, WPA, and WPA2. Can you try changing your wifi security to WPA2 instead of WPS? Then give either the iOS app or particle setup another try.

I will try that when I’m back in town. Thanks.

I’m back in town and have tried a few more things with no success. I even tried no encryption (open) on my 2.4 ghz SSID and I could not configure a photon using the IOS app or the CLI (particle setup). Here’s the dump from the CLI:

[ ~/.particle ] particle setup
                  _   _      _        _
 _ __   __ _ _ __| |_(_) ___| | ___  (_) ___
| '_ \ / _` | '__| __| |/ __| |/ _ \ | |/ _ \
| |_) | (_| | |  | |_| | (__| |  __/_| | (_) |
| .__/ \__,_|_|   \__|_|\___|_|\___(_)_|\___/
|_|                     https://particle.io/

> Setup is easy! Let's get started...
> It appears as though you are already logged in as neil@oblique.com
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

! PROTIP: Wireless setup of Photons works like a wizard!
! PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
! PROTIP: You may lose your connection to the internet for a moment.

Potentially unhandled rejection [2] Unable to find mac address in response (WARNING: non-Error used)
? Found "Photon-PKFW". Would you like to perform setup on this one now? Yes

! PROTIP: You will need to know the password for your Wi-Fi network (if any) to proceed.
! PROTIP: You can press ctrl + C to quit setup at any time.

! Woops. Something went wrong connecting to Photon-PKFW. Please manually re-connect to your Wi-Fi network.

I’m going to PM you (bryce) with my phone so you can call me. Something is very wrong here.

1 Like

And, just to clarify, I do not have WPS on my NetGear router. I’ve tried all flavors of WPA(2) and also NONE with no change to the setup results.

I was able, after many refreshes of app and IDE, to get my manually configured Photon to Flash from the IDE and to show up as configured on the IOS App. It says Online, non-Tinker. So, I can finally play with my Photon. This was the photon configured with particle serial wifi and then added to devices using the IDE Add New Device option after getting the ID from CLI particle identify.

The particle setup and IOS setup both continue to fail every time.

MORE DETAIL:

After trying to configure another of my Photons manually I can’t seem to repeat the magic. It took about four Factory Resets to get the CLI to show me the MAC address. Once I had that, the Setup Wifi went fine and that MAC shows up on my wifi list on the router info page. BUT: it’s flashing fast blue (not pulsing) and I cannot claim the device ID.

Hey Bryce,

I’m still unable to configure two out of three of my photons using any tool path. This is pretty frustrating. What do you suggest?

UPDATE: I tried again to manually setup a photon and the particle serial wifi succeeds but leaves the photon flashing fast blue. Your doc says this is trying to connect to Particle Cloud. I’ve confirmed the photon is on my wifi listed as WICED DHCP Client so the problem does not appear to be a connection issue between the photon and my network.

I wanted to chime in, I bought two Photons. The first one got this same symptoms: on particle-cli, the “Unable to find mac address in response” error, and on the app, failing at the Verify Product Ownership step.

The second photon set up fine on the same wireless network (I did skip all the wireless debugging in this thread because of this). I think you may want to investigate this as a problem with the hardware, not a problem with the wireless.

The one difference between the two is the first one, I immediately soldered it to an LED panel - touching the VIN, GND and D3 pins. After getting the second one working, I took the wires out of those pins, and still got the same issues. I’m pretty confident my soldering didn’t mess up the board, but I wanted to include this info in case that rings some bells :slight_smile:

Kristina

2 Likes

I’m experiencing the exact same symptoms with one of my Photons (we got a shipment of 5) as @TogaDriver . Tried two recent Asus routers, tried with WPA2, open, 2.4 and 5ghz, channels below 11.

With iPhone setup it gets stuck at “claiming photon”, if I try to set it up trough my PC (node installed properly, firewall open, photon driver installed ok as COM3 port), it doesn’t even detect the Photon via USB or Serial … And then on OSX it detects it but I get the exact same errors as TogaDriver.

The “photon identify” id is: 1e003e…

Has there been any progress in debugging this? There is no way for me to use my Photon right now.

@jures,

what does particle --version say? Plug the Photon on and make sure it is blinking blue.

Use particle serial wifi to setup :wink:

@kennethlimcp ,

I did a hard reset first (10 seconds).

particle --version reports 1.5.11
I tried particle serial wifi, this was the response:

Attempting to configure Wi-Fi on /dev/cu.usbmodemfa131
I said: w
Serial said: SSID: 
I said: XXXXXX
Serial said: XXXXXX
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 
I said: 3
Serial said: 3
Password: 
I said: XXXXX
Serial said: XXXXX
Thanks! Wait while I save those credentials...
Done! Your device should now restart.

It restarts and gets stuck on blinking cyan.

Does it simply blink cyan forever? Is there red flashes?

Immediately after serial wifi setup it blinks cyan, then a flash or two of really fast red, then cyan again, fast red, cyan again. After some time it just flashes cyan.

Ok cool It sounds like…bad keys maybe. Try this.

  • place the Photon in listening mode
  • particle serial identify to get the device id (skip if you have it)
  • particle keys new junk
  • particle keys send device_id junk.pub.pem

Once done, reset the core and see if it connects

Ok, I created the keys files: (XXX.der, XXX.pem, XXX.pub.pem).
When I run the last command:
particle keys send XXX.pub.pem
I get this error message:
Please provide a filename for your device’s public key ending in .pub.pem

(the XXX is the long alphanumeric code I got from the identify command))

Opps sorry. the command is particle keys send device_id device_id.pub.pem