Photon: Failed to claim device, server said: [object Object]

Hello,

trying to setup my Photon via CLI and I get this error when claiming:

particle device add 260037000xxxxx

Failed to claim device, server said: [object Object]

Any idea what this means?

Markus

Was your device online when attempting the claiming (breathing cyan)?

No, it’s blinking green. I tried the app but it fails on the last step claiming the device.
I am using the same password as for my Core devices and they work just fine.

In order to claim a device the cloud needs to have access to it.

Are you using the Particle App with the Photon?
The Spark App won’t work with Photon.

I am using the latest Particle app on iOS

When using the CLI in listening mode, could you try particle serial wifi and follow the steps provided?

here are the results:

particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: 2WIRE907
? Should I try to auto-detect the wireless security type? Yes
Detected WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP) security

it does not come back with a prompt after the last line

Could you try not having it auto-detect? Might help.

OK, I just did this:

? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: 2WIRE907
? Should I try to auto-detect the wireless security type? No
? Security Type WPA2
? Wi-Fi Password *******
Done! Your device should now restart.

Works great with the Core, but the Photon keeps blinking green!

Hmm, strange…
Could you make sure your CLI is updated by doing npm update -g particle-cli?
Then, place your device in DFU mode and issue particle update.
Then, DFU once more, followed by particle flash --usb tinker.
Once that’s done, go in to listening mode, and try particle serial wifi once more. Just to be sure, try clearing your credentials first, by holding MODE for 10 seconds.

Did the entire run-thru (including 10 sec mode button) but it still ends up blinking green for a minute and goes to blink blue.

In case you hadn’t already done so, could you try taking off any attached circuitries, and try a different USB cable/port/supply?

I’m having the same issue on 3 of 75 P1s. Used the CLI and android phone app but always fails to connect to the cloud. My rgb rapidly blinks cyan then momentarily blinks yellow/orange then back through the cycle. I have a video of it but I cant post it on here.

That’s not really the same, is it? We’ve got blinking green to deal with, whereas you’ve already passed that stage. I suggest you do a quick forum search for ‘orange’. The pattern you’re describing sounds like a keys issue, which should be resolved by using the Keys doctor in the CLI.

1 Like

I will try that but as I said I did exactly the same in DFU mode with my Core and that works just fine. Can the hardware be faulty?

Just ran it again with a different cable: same result.

Considering the LED is still working, I doubt that it’s a hardware issue. Yesterday or so I noticed that getting a decent connection while the photon was in an internet button was a lot harder than without it. Hence the suggestion to take off external circuits, and try other power supplies/cables :slight_smile:

@Moors7, Thanks, I now realize I miss posted here. I tried the keys doctor again and it work this time around. Before posting I had already tried the keys doctor a few times before but it didnt work. Not sure why it worked now but its now connecting to the cloud.

1 Like

It is sitting on an empty breadboard, any other suggestion?

I looked at my router log and there is no entry of the MAC address of the Photon. Anyone seen this before?

So tried different cables and re-flashing without any success.
Do I have to assume the Photon has a HW issue?
Is there a warranty on the Photon?

I just created a new topic: Photon does not connect to ATT U-verse 3801HGV router
because the Photon works just fine in another Wifi network.