Cant claim Photon

I turned my photon on today and for some reason it would not connect. I tried to re flash it with the particle app, it got as far as claiming ownership and then it fails. It will then sit flashing very fast cyan, a burst of red, then burst of one green, then back to cyan again. I can enter dfu and safe mode and listening mode.

I reinstalled the 0.5.2 firmware (using this process DFU Flash In Windows) and tried to claim via the particle app and it got as far as claiming and fails saying it cant claim.

Where do I go from here?. Any help is appreciated.

Your post is identical to this one. Particle Photon WiFi Setup

Protip:
If you use the search button on the forum, you will often be able to find the answers to your problems.

I did use the search feature, that post isn’t very helpful tbh. I have found lots of posts, but the information is strewn across many post with many contradicting themselves. I am trying to install the cli on windows now (what a nightmare), there really should be a download from particle that makes this super easy for the bajillion windows users out here :).

From what I can gather I need to send a new key to the server or something like that. Ill continue messing about until someone else might chime in with some info.

Thanks

1 Like

Would this page help? https://docs.particle.io/guide/tools-and-features/cli/photon/

Here’s the cli installer for Windows by the way. https://github.com/mumblepins/Particle-CLI-Installer

This would have helped yeah, bookmarked . I just dl those all separate anyway and installing now.

1 Like

If only they provided some sort of official installer. Instead there’s only an official installer available at the bottom of this page. Oh, wait…
https://www.particle.io/products/development-tools/particle-command-line-interface
(Now perhaps preferred over Mumblepins)

If safe mode works as you say it does, then the keys should be fine. It’s then most likely your firmware being problematic. Try flashing back tinker using the CLI/DFU.

1 Like

If only there weren’t 1700 threads telling me 27 ways to do it over the last two years. Yes, it does work as I say in safe mode. It fails specifically at claiming. I wanted to make sure there is nothing wrong on the cloud side as well.

To be fair, it’s a community forum, not an official source for information. Those would be the website and the docs. That’s not to say the community doesn’t contain useful information, but you can’t blame it for being a bit more spread out.

Then you should be able to claim it when it’s breathing magenta. If you’ve got the Device ID you can do so in the Web IDE, or without it using the CLI. First place it in Safe Mode, then place it in Listening mode. Then issue particle identify using the CLI. The ID that’ll give you can then be inserted in particle device add [ID] after placing the device in Safe Mode again.

Alternatively, if you’ve got the CLI installed, place it in DFU mode and issue particle update, followed by DFU and particle flash --usb tinker. That should help remedy the issues you’re seeing after which the app should work again, as well as either of the methods mentioned above.

Thanks I’ll try this out. Any idea what the actual issue is? Or what causes this? . I cant have this happen in the field lol

Considering Safe mode works, it’s likely your code being problematic. Without knowing what’s on there, it’s hard to tell though.

Should you still be looking for a Photon tinker.bin (the one you mentioned was for the Core), the official one is here: https://github.com/spark/firmware/releases/download/v0.4.9-rc.3/tinker-v0.4.9-photon.bin
(that’s included with the CLI and will be installed while doing the commands mentioned previously)

I got it to work again by doing this after the cli was installed and opening a nodejs prompt.

1.) Put the Photon in DFU mode (blinking yellow).
2.) CMD: particle keys save mykey
3.) CMD: particle keys send DEVICE_ID mykey.pub.pem
4.) reset the device (unplug from USB and plug back in)
5. Claimed it in the web ide.
6. Flashed blink an led test app.

Voila

I will write up a new tutorial when I get some time for any one else that may have this happen. My keys were corrupted it seemed. I wont be able to put this into production until I find out why this happens as it seems to happen often enough to cause a problem.

Thanks for the help Moors7

1 Like

that somehow doesn’t line up with

If the keys were corrupted you should not have been able to get into Safe Mode (breathing magenta) :confused:

However glad you got it working and sorry for the bumps on your way.

Very well could be, that’s just my guess tbh.

It simply would not connect without me having to send a key to the server via particle cli. then bam it connected right away. I had reloaded the .5.2 firmware lots of times by that point as well as flashing public keys etc lol.

Now I am more concerned as to WHY it happened and how to prevent it. As I said earlier, things like this completely take it out of a consumer unit for me at this point

I intend to put these in very high value devices and I cant just have it crap out for no apparent reason. Its not my code as I even flashed the blink led example app and that wouldn’t work (connection wise). Still could be my fault somehow, but I have to trouble shoot until I find out why it happened.

I see in the forums this is a common issue with no one really knowing what the issue is/what causes it. I cant re flash this thing if its 2000 Miles away and not connected lol