Photon does not connect to ATT U-verse 3801HGV router

I tried everything (reset router, use the Particle app, command line, update firmware ) to activate my Photon at home but it keeps blinking green.
So I went to a friends house and used their wifi connection and big surprise: all went fine!
I am using an ATT U-verse 3801HGV router and there seems to be a big communication issue.

Anyone experiencing the same issue?

ps. I have 2 Cores and they work just fine with the router.

It looks like these routers use a default encryption key that is in hex (not ASCII) from a label printed on the bottom of the device unless you configure it otherwise. I am not sure a hex encryption key will work with Particle, so I would try a different ASCII value for the key.

The password is printed on the router as ASCII and my router works just fine with my two Core.

1 Like

U-Verse… Just Say No.

Are you using WEP or WPA2?
If you are using WEP (which I guess from your reference to the default password), you should have considered to take @bko’s advice serious.
The Core might work well, but the Photon uses a different brand WiFi module, hence there was a thread about the peculiarities of WEP on the Photon

But my personal advice would be to use WPA2 instead of WEP otherwise you can leave your WiFi open just as well.

1 Like

@ScruffR: Just looked at the settings: WPA-PSK (TKIP) and WPA2-PSK (AES)

Should that work?

That should work.
Does this mean your router was already set to that or that you’ve got the option and will try with it?

I’d go for WPA2-PSK (AES) only - having TKIP/AES mixed can (slightly) slow your network down - it’s only required if you have devices that only support TKIP.

This is the default setting of the router and I did not change that. I am not worried about the speed at this point. I just want to be able to use the Photon.

@ScruffR I borrowed an Airport Express from a friend and use this as the AP for the photon. It works now but there is definitely an issue connection to the ATT U-verse 3801HGV router directly.