Connectivity - can't connect to one particular WiFi network


#1

I’ve been working with the Photon for a year now and for some reason there is ONE wifi network that I can’t seem to connect to. I’ve tried using the Particle smartphone app, the USB method, as well as the method outlined at setup.particle.io. No matter which Photon I use, they can’t seem to connect to this one network.

Here are some details:

  • 2.4 Ghz router, with 802.11b/g, WEP (model: “2-Wire 2701HG-G”).
  • All other devices are able to connect to this wifi network (ie. smartphones, PC’s, tablets, Playstation etc.)
    -Photon just flashes green indefinitely.

I was hoping that a quick search of the model# would provide me with links to other folks who were having this problem - but no luck.

There is a firewall set up from what I can tell, but not sure why every other device can connect without issue.


#2

If it’s using WEP, have you seen this?


#3

Thanks a lot. I’ll look into using that method to connect my Photon. I don’t plan on using WEP for the longterm, but it was kinda bothering me not knowing why I couldn’t connect.


#4

Do you know if the WiFi device is an actual Access Point? It may be necessary for the photon’s mac address to be configured and allowed to access the WiFi in the AP’s management configuration? Just a quick thought.


#5

Thanks to all that replied. This was just related to how I was entering the WiFi network’s passphrase. There are some Hex digits that need to be inserted at the front-end of the passphrase for WEP networks.


#6

So it works now :)?


#7

Yes - it worked. Problem resolved. :slight_smile: