Failed to claim device, server said { ok: false, errors: [ 'device does not exist'

Hello,

I´m was eager to start tinkering with my sparkling new „internet-button“.
But no luck so far.

I replaced the core id with “xxxxxxxxxxxxxxxxxxxxxx”

"Your device id is xxxxxxxxxxxxxxxxxxxxxx
bash-3.2$ particle login
? Please enter your email address: dreger@me.com
? Please enter your password: *******

Successfully completed login!

bash-3.2$ particle device add xxxxxxxxxxxxxxxxxxxxxx
Claiming device xxxxxxxxxxxxxxxxxxxxxx
Failed to claim device, server said { ok: false, errors: [ ‘device does not exist’ ] }

Using the „particle setup“ I get this;

Obtaining device information…
Requesting public key from the device…
Setting the magical cloud claim code…
Telling the Photon to apply your Wi-Fi configuration…
The Photon will now attempt to connect to your Wi-Fi network…
> Configuration complete! You’ve just won the internet!
? Would you like to return this computer to the wireless network you just configured? Yesnfigured? (Y/n) y
! It doesn’t look like your Photon has made it to the cloud yet.

Using the iOS App to setup, the app claims there is something wrong with my wifi-connection. (Which isn´t the case.) I think it´s also trying to claim the device an gets the same “[ ‘device does not exist’ ]”.
Tried to contact "hello@particle.io", but got no response. (sad)

Ping @corey

1 Like

@desq just responded to your ticket. awaiting your response.
Just off the top of my brain, it seems that you’re potentially trying to connect to a network that is not
2.4GHz WPA2. Or behind a firewall…

-Corey

@corey thank you for your reply. After 3h of tinkering and several reboots of the photon it works. I tried so many different things, that I can´t really say what it was.
(By the way, my wifi network is a 2.4GHz WPA2.)
Perhaps the “particle update” did the job.

-stefan

2 Likes

that’s good to hear! :smile:

feel free to ping me again if you need any more help.

-Corey :sunglasses:

1 Like

@corey I seem to be having the same exact problem as @desq were there any more ideas beyond confirming no firewall and 2.4 GHz wifi? I tried doing the setup on an Android, an iPhone, and through the command prompt on a Windows using this thread “https://docs.particle.io/guide/getting-started/connect/core/” and this one “[Howto] Setup photon if docs step fail” and redoing both threads with a different USB cable. I have also attempted to claim the device directly using the ID through the build website but I get a “doesn’t exist” error. Thanks for your help.

can you give that device a firmware upgrade?
https://docs.particle.io/support/troubleshooting/firmware-upgrades/photon/#the-simple-way-one-cli-command-

then try setting it up.

-Corey

That thread takes me to a walk through for Apple computers while I have a windows and I get to the “brew install dfu-util” and brew is unrecognized. I attempted to find other instructions for a Windows and I found “http://blog.jongallant.com/2015/08/particle-photon-firmware-flash-windows.html” which I get lost at the fourth step adding the files to my path. I also found this “https://docs.particle.io/guide/getting-started/modes/photon/#dfu-mode-device-firmware-upgrade-” which has a link to what seems would be an installation tutorial for dfu-util but actually takes you to a dictionary of commands. Do you have a better link or could you help walk me through the confusing steps of the first link? Thanks.

if you’re super interested in getting CLI & DFU tools setup on your windows machine, then I recommend using this tutorial for that here: [Particle Official] Windows 10 Full CLI and DFU Setup

but from what i’m reading, it seems like you’re device was shipped with some semi-faulty stock firmware. which is prompting me to tell you that you need a device upgrade.

I’m not really interested in messing with the firmware unless that is going to fix the problem. To be honest I just want to start writing programs. So your recommendation is to buy another photon?

sending you a message.