Verify device Ownership keeps failing (photon)

Hi there,

After working for nearly a week now, my Photon re-started after a power failure at my house and ever since I’m not able to get it back on it’s feet.

Current state is the flashing Cyan led.

After reading many entries on this and other forums, I’ve updated the firmware, deleted and installed keys, updated other things (with CLI) but whatever I throw at the little device, it keeps refusing to verify device ownership.

Since it already have worked, and therefore claimed, I have the feeling that it is not the device but the connectivity to the Particle cloud. I’ve issued commands on the CLI that should have cleared my keys, but I’m not sure if that worked.

When put the Photon in Setup and entered the credentials my phone app tells me that Wi-FI credentials are OK, the connectivity to Wi-Fi network works, the cloud connection is checked as well the internet connectivity, but it keeps failing at the Verification of the device ownership.

I may add that I have two Photons and the other is working very well (as this one did) so WiFi settings and Firewalls should be a problem.

I reset my Airport, no luck either.

After 10 hours of reading, installing and re-trying I’m a bit numb and any help is very much appreciated

Many Thanks, __Frank

Out of interest, what forums exactly?

Any peculiar output from the CLI during those procedures?

Any other colors present in the flashing sequence (red/orange in particular)?

Any chance you could shoot a video of the pattern from boot?

Basically the ones on particle and I’ve read many of your hints and tips! But still I’m struggling, I’m sorry to say,

Frank

When rebooting the particle it first flashes green and than blinking cyan… and keeps doing it. No other colours (red or green).

I might do a video, hold on

It seems that I’m not allow to upload a video, but it stat flashing green and after a couple of seconds cyan. Every now and again it flashes green, but typically cyan. Do you need specific output from a specific command. I might re-run it for I’ve run a dozen of commands …

While in DFU mode, issuing particle update as well as particle flash --usb tinker would be nice.

1 Like

Hi Moors7,

I really appreciated your help. Here you’ll find the responses of the commands:

xxxx:~ thewall$ particle update

**> Your device is ready for a system update.**
**> This process should take about 30 seconds. Here goes!**

**! System firmware update successfully completed!**

**> Your device should now restart automatically.**
**> You may need to re-flash your application to the device.**

And

xxxx:~ thewall$ particle flash --usb tinker

**Found DFU device 2b04:d006**
**checking file /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin**
**spawning dfu-util -d 2b04:d006 -a 0 -i 0 -s 0x080A0000:leave -D /usr/local/lib/node_modules/particle-cli/binaries/photon_tinker.bin**
**dfu-util 0.9**

**Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.**
**Copyright 2010-2016 Tormod Volden and Stefan Schmidt**
**This program is Free Software and has ABSOLUTELY NO WARRANTY**
**Please report bugs to http://sourceforge.net/p/dfu-util/tickets/**

**dfu-util: Invalid DFU suffix signature**
**dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!**
**Deducing device DFU version from functional descriptor length**
**Opening DFU capable USB device...**
**ID 2b04:d006**
**Run-time device DFU version 011a**
**Claiming USB DFU Interface...**
**Setting Alternate Setting #0 ...**
**Determining device status: state = dfuIDLE, status = 0**
**dfuIDLE, continuing**
**DFU mode device DFU version 011a**
**Device returned transfer size 4096**
**DfuSe interface name: "Internal Flash   "**
**Downloading to address = 0x080a0000, size = 3952**
**Download	[=========================] 100%         3952 bytes**
**Download done.**
**File downloaded successfully**

**Flash success!**

In addition, I’ve worked with other commands as well. When I issue

**xxxxx:~ thewall$ particle serial identify**

**! serial: Serial timed out**

In reading your comments on other entries I’ve done a couple of things yesterday:

xxxx:~ thewall$ particle keys save mykey --force
Found DFU device 2b04:d006
Saved!

and

xxxx:~ thewall$ particle keys send 2a0024001751353338363333 mykey.pub.pem
attempting to add a new public key for device 2a0024001751353338363333
submitting public key succeeded!

I’m not sure if I should have done the last step, for I already registered the device. In the Particle portal I’ve fiddled with the device and unclaimed it and deleted it. It is not shown there anymore but I can’t add this device anymore.

Any idea?

Many thanks,__Frank

For this your device should be blinking blue (Listening Mode)

To add your device after unclaiming it (which never helps in such circumstances anyway) you can do

particle device add <yourDeviceID>

But for that the device needs to be breathing cyan or magenta (cloud connected)

The easier way to correct your keys if the went out of sync would be

particle keys doctor <yourDeviceID>
particle keys server

(both in DFU Mode)

You may also want to clear your credentials (hold SETUP 10+seconds till rapid blue flashing) and reenter them via

particle serial wifi

(in Listening Mode and don’t choose auto-scan but do everything manually)

To post a video, you can upload it to YouTube (or any other similar platform) and post/embed a link

2 Likes

Aha! Results! that did the trick ScruffR!

I’m not sure what happened in the first place, but the Photon is back on line.

Many thanks!

Have a nice weekend!

__Frank

2 Likes