Device ownership


I don’t succeed anymore to claim the ownership of a new Photon.
With my smartphone I succeed to enter the credentials for WIFI. Everything goes perfect, but the last step ( claiming your device to the cloud) is everytime refused.
This device was already unclaimed once, ( on the same credentials) but reclaiming doesn’t succeed.
Sometimes I get the message my tokens are not valid anymore, but nothing was changed on my credentials and my other Photon-devices are working perfect : on those devices, I can flash new programs as many times as I will.

On my device I get during some seconds a cyan led fast flashing, after that three times yellow flashing. After that again cyan flashing,and after that once red flashing. And so over…
Is there somebody that can give me a solution ?
on beforehand thx.

Claiming is only possible if the device is breathing cyan. If it’s in any other state, claiming will always fail.

Is it possible that there are three orange blinks instead of yellow? If so, you might have bad device keys. See the instructions [here])(Device Blinking Cyan | Troubleshooting | Particle) for resetting your device keys.

THX for your help !
My problem was indeed : “bad keys”.
Following your instructions I succeed to renew my (corrupt ?) keys and claim the device to my account.
My device is again connecting to the cloud as usual.

Again : THANKS foor your help !

Sorry, Again I have to ask for help.
As said before, yesterday I succeeded to renew the keys and to have the cyan blinking. I also succeeded to flash a small program for a test…
Today, trying to flash a new program, nothing was done. The device didn’t accepted the program athough the program screen is saying : flash succeeded. Device will restart.
On the device nothing was happening. ( cyan led stay still blinbing)
I tried to renew the connection with my wifi via DOS-screen. Everything OK, but flashing still without succes.
I tried to renew my WIFI-connection via iPhone. Connected to my iPhone I got the device identification art-FTEKCQ, but this isn’t recognised in the Particle screen.(the program is mentionning : PHOTON + 4 digits…)
After repowering, my device seems perfectly connected to my WIFI.
(led blinking green and after 10 secobds becoming straight cyan)
But still no flashing succes.

What can I do to have this device correctly connected ?
Bad device ?

On beforehand THX

I’d guess that your firmware is probably doing something that is preventing it from accepting the update.

First try putting the device in safe mode. Hold down SETUP and tap RESET. Continue to hold down SETUP until the status LED blinks magenta (red and blue at the same time), then release SETUP.

Wait until the device breathes magenta, then try flashing OTA.

If that works, then you are probably doing something in your firmware, like blocking setup or loop from returning. Another option is to enable threading near the top of your main source file:


Again THX for your help.
But, as newbi, I don’t have a lot of experience with this.
I have to set my device blinks Magenta. Done
Try flashing OTA.
What is it ? Where can I find it ?

The other option (System_Thread…). I understand I have to put this command on top of my source file : but as I cannot flash this device. I don’t see how.
Also via serial I don’t succeed to load a program.

It’s strange, I have four Photon’s. One is working for a temperaturecontrol on nine places from my floorheating since 2018. Without problems. Sometimes I change the working device. Without problems.

Only one of my Photons, the last I bought, is giving all that problems.
Shall I see for another new one ?

Again THX for your understanding and help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.