Photon suddenly failing to connect to cloud, won't verify product ownership

I was using my photon successfully for a while, until suddenly it started failing to connect. It flashes cyan quickly for a while, then I get two short orange flashes and the process restarts. It seems that it’s failing to connect to the cloud. I’ve tried everything I can find online relating to troubleshooting wifi issues, resubmitting submitting keys, flashing different firmware/bootloader - anything I could thing of, but the problem persists. I tried removing the device from my account, but now when I connect to it via the app and attempt to reclaim it, the process fails at “verifying product ownership.”

So I bought another one. Just took it out of the box, plugged it in, and opened up build.particle.io to put my code on it. Code flashed successfully, and then I see a message in the bottom that it’s updating the device. After that, I now have two particle photons with the same issue. I’m at my wits end. Can anyone offer me some guidance here? I just want to finish this project.

I was just looking into this further, and it seems that both devices are currently running the latest firmware (0.7) though when they last connected to the cloud successfully they were on 0.5.3. It seems that updating the firmware via build.particle.io is what caused the issue. Still can’t find a solution.

Manually reflashed to 0.5.3 with dfu-util and it can connect again. There must be an issue with the 0.7 firmware.

Alright, I’m going to pull my hair out. With the 0.5.3 firmware from github it’ll connect just fine, and I can flash code to it. The problem is, none of the code runs - not even the test code they provide. I’m pulling my hair out here.

What test code and what does the device do?
Maybe you install Particle CLI 1.30.0.
Then update the device via that (particle update) .
For safe measure you can then manually also update the bootloader particle flash --serial bootloader-0.7.0-photon.bin
And finally reflash Tinker via particle flash --usb tinker and test if this at least runs.

If you don’t want to run 0.7.0 again or have troubles with it try going with 0.6.4

Sorry for the delay in updates, I worked out that I can still flash code to it via USB, but OTA updates are failing even though they say they’re successful. I’ve just been flashing my two photons via USB while running the 0.5.3 build from github, which seems to be the only os firmware that allows them to authenticate with the particle cloud.

I can confirm that manually flashing to 0.7 via any method causes it to fail to authenticate to the particle cloud. I’ve tried flashing other versions as well, but the only one that seems to allow it to auth is 0.5.3. The only issue now (besides not being able to run current OS firmware) is lack of OTA code update ability.

With the Photon in listening mode (blinking dark blue) and connected by USB, can you do:

particle serial inspect

I suspect you have a bootloader conflict.

Note that you should never downgrade from 0.7.0 to 0.5.3 directly. It won’t work properly, and can make it impossible to use and DFU mode (blinking yellow) operation that access the DCT (configuration flash). You should instead downgrade to 0.5.5, then either stay there, or downgrade a second time to 0.5.3. Going to 0.5.5 or 0.6.3 downgrades the bootloader, which is necessary when downgrading from 0.7.0 or later.

I appreciate the advice, and I suspect you’re correct about the issue. It seems I inadvertently selected 0.7.0 as the firmware version in the web IDE, as it was marked as the “default” option. I’ve read some things since then that upgrading from 0.5.3 to 0.7.0 requires an upgrade to an intermediate version first. I’ll attempt the downgrade to 0.5.5 and let you know how it goes, thanks again for the help!

Flashing 0.5.5 via USB allowed it to reconnect the particle cloud and immediately reload the last project I had pushed to it OTA from the web IDE. Problem solved! Thanks!