Photon (bought in 2016) cannot connect to cloud

Hi there,

I bought a Photon in 2016 and used it for a while. It hasn’t been used for a couple of years and I’m trying to get it working again.

  • I’ve installed latest firmware (I think) via particle flash --usb tinker.
  • I’ve reset the device via particle device doctor. It connects to wifi OK as I can see the Photon in the router’s DHCP page. The Photon is stuck in fast cyan blinking with red blinks every 10sec or so. This seems to be that it cannot connect to the cloud. The device was claimed in my account for years, but I’ve unclaimed it before this process to start fresh (maybe this wasn’t a good idea).
  • I’ve also tried particle keys server and particle keys doctor <DEVICE_ID> to no avail.

I’ve tried all these steps a few times. Any ideas?

Many thanks!

Hi Peri, and welcome to the community!
can you try the device restore tool?
Best,
Gustavo.

1 Like

Hi Gustavo,

Thanks for the quick reply and the suggestion. I’ve run the device restore tool successfully but I’m still having the same problem.

I’m now sometimes seeing 3 orange blinks in between cyan blinking segments, which seems to be related to server keys (the rest of the time is a red blink). I’m not sure about these, but they should have been reset with the particle keys server and particle keys doctor <DEVICE_ID> commands I’ve tried a few times.

Many thanks.

i’ve been adviced by particle team to do following - and it worked for me + check your USB cable
in my case some of them work well and some don’t:
Can you unplug it, hold down the SETUP button, plug in USB power, and continue to hold down SETUP until the LED blinks yellow, then release: If it stays in blinking yellow you should be able to use the USB Device Restore tool or particle update .

Hi Anton, thanks for the suggestion. The cable works fine and I’ve tried configuring the Photon via cli and via the device restore tool several times. All commands run fine and communication with the Photon is fine.

I suspect the issue has to do with keys & claiming the device. At the moment, the device is unclaimed. Its LED blinks an error code that signals incorrect keys and it cannot connect to the cloud. Given that it cannot connect to the cloud, I cannot claim it. I’ve tried restoring its keys with particle keys server and particle keys doctor <DEVICE_ID>, which run fine, but it doesn’t fix the problem.

@Colleen can you assist here, please?

2 Likes

Thanks Gustavo, any help would be appreciated.

Sorry for the delayed response! Have you run the device doctor?

Hi Colleen,

No problem!

I hadn’t tried that tool. I’ve run it now, and it gets stuck in the Connect to cloud step, with the following error message:

0000004321 [app] INFO: Auto-connect disabled
0000004647 [app] INFO: doing wifiScan
0000004655 [app] INFO: Doing Wi-fi scan
0000005405 [app] INFO: wiFiScan resultCount=4
0000028954 [app] INFO: setting credentials
0000032775 [system] INFO: Cloud: connecting
0000032945 [system] INFO: Cloud socket connected
0000032945 [comm.protocol.handshake] INFO: Establish secure connection
0000033261 [comm.protocol.handshake] ERROR: Handshake failed: 26
0000033415 [system] WARN: Internet available, cloud not reachable
0000033415 [system] WARN: Cloud handshake failed, code=-220
0000033665 [system] INFO: Cloud: disconnecting
0000033667 [system] INFO: Cloud: disconnected

Many thanks.