Photon cannot connect to cloud after firmware update

Im very new to Particle devices. I started with photon yesterday. Then today I updated the firmware through CLI as it was apparently not updating while flashing codes from Web IDE. But after updating the firmware, photon cannot connect to cloud. I always reaches to blinking cyan LED but never to breathing cyan LED. I tried many solutions available in the forum but none of them worked so far. But I am not sure if I am doing things correctly as I am very new to it. So any help would be appreciated.

Is this very recent? See the status warning of a service outage at the top of the page.

I have two xenons which were reset in the same state. The first reset when I was plugging something live while debugging and caused a short, so I thought I had broken it!

For me, have lunch and hope it will all be better :slight_smile:

Okay so I did not know about the outage. But seems like all systems are operational now and I tried again. But still I am encountering the same problem. Not able to connect to cloud.

Hi @kkpradhan -

You are right in the fact that the blinking Cyan is referring to not being able to connect to Particle Cloud.

Without some code to see, it is a bit more difficult to troubleshoot. Is it possible to share some or is it too much? Alternatively, can you flash the tinker software via the CLI and see whether it resolves the problem. Then re-flash your firmware. If the problem resolves itself with Tinker but re-appears when you flash the firmware, we know were to start looking.

if flashing tinker does not work, we also know in which direction to look :slight_smile:

Regards,
Friedl.

1 Like

Hi @friedl_1977,

Thank you for your response. I tried flashing tinker via CLI but that does not resolve the issue. Also, I tried flashing a debug software to monitor the WiFi connection through serial monitor. I notice it says, “failed to get device.spark.io from DNS”.

I also tried following some advice on the forum to use keys or doctor but still didn’t resolve the problem. So Im bit lost on what to do next.

Seems like the issue is with the WiFi network I am using. I am trying to connect through my office network. It was working before the firmware update. But for some reason it is not working now. But when i try to connect through the hotspot of my phone, it works. I can connect to cloud. So I am bit confused why photon is not able to connect to cloud through my office WLAN after update.

HI @kkpradhan -

Have you tried restarting the router in an attempt to change your Public IP? I know it seems trivial but sometimes we get assigned a public IP that causes some headaches.

Of course on networks there can be several things causing this, but if it was working before and the only changes was the firmware update it seems unlikely and the first thing I would try is restarting the router :slight_smile:

Please let me know.