Photon disconnects from cloud and breathes green

photon
Tags: #<Tag:0x00007f1ca6780860>

#1

I am having a problem with my Photon connecting to the cloud.

I have tried unclaiming it, reclaiming it, erased the wifi credentials, upgrading the firmware, upgrading particle CLI.

It doesn’t connect long enough for me to flash any code via the cloud. Everytime I reset it, it connects for around thirty seconds, then goes to breathing a slow green (no cloud connection). I am unable to claim the photon on my laptop, after I enter in the serial number it tells me that it’s unable to claim this device. That is after I unclaim it. I can always claim it through my mobile, but at the end of the set-up process it tells me that my photon was successfully claimed but is now offline so it can’t complete the setup. I’ve tried putting in dfu mode, i’ve tried using the CLI to use the device doctor. The only way I can flash code to it is through dfu-util. Thanks for any help


#2

You didn’t mention having tried Safe Mode, have you?


#3

The fact you have WiFi connection but no cloud connection leads me to ask - does your WiFi have internet connection and if you are in a managed environment (e.g. not a home WAP) has the port been opened for TCP traffic to the Particle cloud? If the device connects but then disconnects it could be the signal strength is poor.

Other than that - are you logged in to CLI with the same account the device was originally setup under? If unable to claim a device this is because it is offline or already claimed by someone else.


#4

Breathing green is typically a user firmware issue. The instructions here (click “More information”) should allow you to get out of it using safe mode.

https://docs.particle.io/tutorials/device-os/led/photon/#cloud-not-connected


#5

I’ve tried safe mode. No luck.


#6

I put it in safe mode and then flashed the tinker app. It’s connected to the cloud again and breathing cyan, but for some reason I can’t flash programs to it. The flash comes back unsuccessful. It’s connected and showing up in the cloud but flashing from the web IDE isn’t working.


#7


#8

safe mode did work after fixing some other issues. For some reason I can’t get my applications in the web IDE to flash to the photon. I was able to use the CLI and flash the LED rainbow program, that is working fine, but it just won’t let me flash any code from the cloud. The code i’m flashing to the photon is an example one, that turns the D7 LED on and off. The code is compiling fine. I just get the below error when I try to flash to the Photon. Thanks for any help


#9

Same problem here but mine stays connected to the cloud but I cannot upload any code.


#10

I figured out that an improper install of dfu-util was causing me some initial problems. After I followed the proper instructions for installing dfu-util I was able to use the particle CLI to do some updates, then I put it in safe mode and now its working again. Thanks for your help.


#12

Problem solved, thank you for your help