Connection Problems--Pulsing White or Green at best [RESOLVED]!

To begin, I’m a total beginner with this stuff and am using this Photon to learn IoT basics. So a week or two ago my photon was working fine and I was doing very basic things. However, even then I had to go through the process of manually connecting it using ‘particle setup’, rather than the purportedly easy way to do it with the mobile app/smart phone. Now, suddenly, I can’t connect at all–I get a pulsing white light every time I plug it in/turn it on, which I’ve read is that the wifi is turned off. I tried doing the ‘particle setup’ process again in the command line, and I get a never ending line of Obtaining Device Information… down my command line. Next, I’ll sometimes be able to “connect” it using ‘particle setup wifi’, but at best I’ll get it to pulse green. So, after several hours of screwing around and getting nowhere, I unclaimed the device and tried to start all over. After doing the steps above I achieved the same results. From there I went through the whole DFU, Zadig, and environmental variables stuff that in which I have no understanding of, I just followed steps in a rabbit chase (Someone should really make an efficient video or thread about this for the dummies like myself). After updating my firmware while in DFU mode with the ‘particle update’ command, I went back to square one. At best, I can only get my LED to pulse green and cannot for the life of my connect to the cloud. I’m now in Safe Mode (or what I believe to be safe mode, my LED is pulsing red/blue at the same time, giving off a “magenta” ish color") and since I can’t actually connect to the cloud, I can’t upload any code. Not only that, but once I do manage to get it into Safe Mode, I don’t even know what code to upload.

I’ve spent close to 8 hours this week trying to get this working, and it is extremely frustrating. Any and all help will be greatly appreciated!

UPDATE/EDIT: In the command line, I did ‘particle flash --usb tinker’ while in DFU mode and now my Photon is pulsing cyan. After claiming this device with ‘particle device add 3c0032000restOfDeviceID’ it actually worked!

For everyone else out there that experiences this problem, there’s hope! After 8 hours of suffering through this, this is what I’d suggest:

-DON’T unclaim the device.
-do a ‘particle update’
-then do 'particle flash --usb tinker’
You may have to go through the DFU installation process, but after that it will work.

Gah this was so frustrating but now I’m so happy this worked! Something as simple as blinking the D7 LED off and on never seemed to beautiful to me…

2 Likes

Good to hear you’re back in the game :+1:

What I guess happened was that you must have flashed some code that somehow prevented your device from connecting to the cloud (e.g. blocking code).
The magenta breathing did in fact tell that there wasn’t any issue with the device or its WiFi setup, and as you found out, unclaiming the device did get you stuck somehow since you can’t flash OTA without having the device claimed.
But reclaiming would have been possible via Build (Web IDE) and flashing a simple

void setup() { }
void loop()  {}

would have been enough to get connected again.

However, good you found your way round and now have CLI, dfu-util and drivers installed, that’s always good to have :wink:

1 Like

Thanks for the response! My question for you now is, when I can’t connect to the cloud, what is the process of flashing specific code to my device? That is, the void setup () {} and void loop (){}. I know it’s a simple question, but I still have much to learn with this stuff!

Since you said

That is an indication that you can connect and actually are currently connected to the cloud :wink:

But if your device really couldn’t connect, you can download the binary by clicking in the :cloud: icon next to the project name in Particle Build and then use

particle flash --usb downloadedFirmware.bin