Unable to flash via the cloud


I started to develop on photons since a week now. During 2 days, I haven’t no trouble, I could compile then flash my firmwares via the cloud. Tuesday, I was attempt to finish my work but when I pressed the button to compile in the cloud (from the web IDE and from Particle Dev), I obtained “Compile success” but then, nothing.

On Particle Dev, it shows me “Flashing via the cloud” but after 10 seconds I have “undefined” instead. From the web IDE, I get “Flash unsuccesfull”. The led on the photons isn’t changing to magenta.

Plus, from the web IDE like from the Particle Dev, when I go in “devices” it’s shows me wrong photons connected. Sometimes I get Photons A is connected and B isn’t whereas it’s the opposite. Sometimes I get my 2 photons connected whereas they are off !

So I tried almost everything :

  • Changed my photon with new ones 3 times
  • Reset them to factory settings
  • Changed internet access for my photons or my PC
  • Changed PC

I had this problems yesterday morning. Yesterday afternoon, it worked, these problems disapear for 2 hours. This morning I could flash via the cloud during 2 minutes but then problems shows up again.

I also tried to compile and flash on my photons locally in DFU Mode, but I had problems in this way too !
I installed the driver correctly, follows the instructions exactly but then when I open the CLI in administrator, I type particle flash --usb firmware.bin (after having compiled) and I get :

Apparently I didn't find a DFU device? util said

Error writing firmware...no dfu device found. 

And in my Device manager I have indeed “Photon DFU Mode”

But for now, I would like at least flash via the cloud.

It could be possible that the problems come from the Spark Server ?

Sorry for my not-very-nice english and have a nice day,


Hi @Raph ,

Sorry for the silence. Did you manage to resolve these issues or are you still unable to flash?



Thank you for your reply. Apparently it came from the first photon I used. When I tested all my others photons, the problem came from the Particle Dev software, with the same problem ! What a beautiful coincidence… It’s should be in Beta Mod, it’s full of curious bugs.

Whatever, I can now flash correctly.



EDIT : After all, this was not a problem of Photon. This problem shows up again today.

I was working on my photon then, suddenly I couldn’t flash anymore. (the led never turn magenta).

So, I tried to update the wi-fi connection of my photon. I pressed the “Setup” button 3 seconds… 10 seconds… 20 seconds, nothing ! It doesn’t turn blinking blue ! I had to turn into Safe mode then the led starts blinking blue. So, I’m telling me, it’s no big deal. I take my phone, launch the Particle app, select my photons, join him to my wi-fi connection then the process starts :

  • Configuring device wifi credentials
  • Connecting to wi-fi network

And then it stop… and it shows me on the app :

On the photons, first it stop blinking blue to turn green constantly, and when the app shows me this mesage, it turn blue constantly.

I repeat the manipulation, it the same, with my 2 photons…

The conditions are the same like describe above.

I’m sure this problem will be gone tomorrow like it does last week but I can’t allow me to lost one day again.

After sending the wifi password to the photon, when the LED turns blue again, please press RESET. It should then connect to your wifi and the setup process on your phone can continue.

I’m sorry for this. This is a known issue in 0.4.4 and will be fixed with a release next week.

1 Like

Thank you very much for your workaround @mdma :smile:
I think I had the same error for the last two days. If I experience it it again I will try the RESET method and let you know if I was successfull.

1 Like

@mdma Thank you I will try that :smile:

However, I have exactly the same problem when my photons was on 0.4.3 (last week). Did the problem was older than that ?

I had one more question : did this problem of synchronization affect the connection to the cloud ? I have to return my work next week, and I can return a system who lose connection anytime.

Previously, the photon would remain in listening mode if it couldn’t connect to wifi. Now, it remains in listening mode even when it could connect to wifi.